summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcf-agent/tcf-agent_git.bb')
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent_git.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
new file mode 100644
index 0000000000..616a6a7a9a
--- /dev/null
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
3BUGTRACKER = "https://bugs.eclipse.org/bugs/"
4
5LICENSE = "EPL-1.0 | EDL-1.0"
6LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
7
8SRCREV = "4ef94ecb927a8912c3d79ce137182247786cff8f"
9PV = "0.4.0+git${SRCPV}"
10PR = "r2"
11
12SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent.git \
13 file://fix_ranlib.patch \
14 file://tcf-agent.init \
15 file://tcf-agent.service \
16 "
17
18DEPENDS = "util-linux openssl"
19RDEPENDS_${PN} = "bash"
20
21S = "${WORKDIR}/git"
22
23inherit update-rc.d systemd
24
25SYSTEMD_SERVICE_${PN} = "tcf-agent.service"
26
27INITSCRIPT_NAME = "tcf-agent"
28INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
29
30# mangling needed for make
31MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686,`"
32MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
33
34EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
35
36# They don't build on ARM and we don't need them actually.
37CFLAGS += "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
38 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
39 -DSERVICE_StackTrace=0 -DSERVICE_Symbols=0 -DSERVICE_LineNumbers=0 \
40 -DSERVICE_Expressions=0"
41
42do_compile() {
43 oe_runmake
44}
45
46do_install() {
47 oe_runmake install INSTALLROOT=${D}
48 install -d ${D}${sysconfdir}/init.d/
49 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
50 install -d ${D}${systemd_unitdir}/system
51 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system
52 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service
53}
54