summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_235.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/systemd-bootchart/systemd-bootchart_235.bb')
-rw-r--r--meta/recipes-devtools/systemd-bootchart/systemd-bootchart_235.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_235.bb b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_235.bb
new file mode 100644
index 0000000000..25544029d5
--- /dev/null
+++ b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_235.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Boot performance graphing tool"
2DESCRIPTION = "For systemd-bootchart, several proc debug interfaces are required in the kernel config: \
3 CONFIG_SCHEDSTATS \
4below is optional, for additional info: \
5 CONFIG_SCHED_DEBUG"
6HOMEPAGE = "https://github.com/systemd/systemd-bootchart"
7LICENSE = "LGPL-2.1-only & GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
9 file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
10
11SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https;branch=main \
12 file://mips64.patch \
13 file://no_lto.patch \
14"
15
16SRC_URI:append:libc-musl = " \
17 file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
18 file://0002-musl-does-not-provide-printf-h.patch \
19 file://0003-musl-does-not-provide-canonicalize_file_name.patch \
20 "
21
22
23SRCREV = "8ab9680a1bd5eb8fe7a7dcc44897af7ee41e56e7"
24
25S = "${WORKDIR}/git"
26
27DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
28
29inherit pkgconfig autotools systemd features_check
30
31REQUIRED_DISTRO_FEATURES = "systemd"
32
33SYSTEMD_SERVICE:${PN} = "systemd-bootchart.service"
34
35do_configure:prepend() {
36 # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
37 rm -f ${S}/m4/intltool.m4
38}
39
40FILES:${PN} += "${systemd_unitdir}/systemd-bootchart"
41
42EXTRA_OECONF = " --with-rootprefix=${root_prefix} \
43 --with-rootlibdir=${base_libdir}"