summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb')
-rw-r--r--meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb42
1 files changed, 21 insertions, 21 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
index dadba9eca9..0dd18d7a06 100644
--- a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
+++ b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
@@ -36,11 +36,11 @@ UPSTREAM_CHECK_REGEX = "syslinux-(?P<pver>.+)\.tar"
36UPSTREAM_VERSION_UNKNOWN = "1" 36UPSTREAM_VERSION_UNKNOWN = "1"
37 37
38# We can build the native parts anywhere, but the target has to be x86 38# We can build the native parts anywhere, but the target has to be x86
39COMPATIBLE_HOST_class-target = '(x86_64|i.86).*-(linux|freebsd.*)' 39COMPATIBLE_HOST:class-target = '(x86_64|i.86).*-(linux|freebsd.*)'
40 40
41# Don't let the sanity checker trip on the 32 bit real mode BIOS binaries 41# Don't let the sanity checker trip on the 32 bit real mode BIOS binaries
42INSANE_SKIP_${PN}-misc = "arch" 42INSANE_SKIP:${PN}-misc = "arch"
43INSANE_SKIP_${PN}-chain = "arch" 43INSANE_SKIP:${PN}-chain = "arch"
44 44
45# When building the installer, CC is used to link. When building the bootloader, 45# When building the installer, CC is used to link. When building the bootloader,
46# LD is used. However, these variables assume that GCC is used and break the 46# LD is used. However, these variables assume that GCC is used and break the
@@ -49,7 +49,7 @@ TARGET_LDFLAGS = ""
49SECURITY_LDFLAGS = "" 49SECURITY_LDFLAGS = ""
50LDFLAGS_SECTION_REMOVAL = "" 50LDFLAGS_SECTION_REMOVAL = ""
51 51
52CFLAGS_append = " -DNO_INLINE_FUNCS" 52CFLAGS:append = " -DNO_INLINE_FUNCS"
53 53
54EXTRA_OEMAKE = " \ 54EXTRA_OEMAKE = " \
55 BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \ 55 BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \
@@ -87,17 +87,17 @@ do_install() {
87# 87#
88# Tasks for target which ship the precompiled bootloader and installer 88# Tasks for target which ship the precompiled bootloader and installer
89# 89#
90do_configure_class-target() { 90do_configure:class-target() {
91 # No need to do anything as we're mostly shipping the precompiled binaries 91 # No need to do anything as we're mostly shipping the precompiled binaries
92 : 92 :
93} 93}
94 94
95do_compile_class-target() { 95do_compile:class-target() {
96 # No need to do anything as we're mostly shipping the precompiled binaries 96 # No need to do anything as we're mostly shipping the precompiled binaries
97 : 97 :
98} 98}
99 99
100do_install_class-target() { 100do_install:class-target() {
101 oe_runmake firmware="bios" install INSTALLROOT="${D}" 101 oe_runmake firmware="bios" install INSTALLROOT="${D}"
102 102
103 install -d ${D}${datadir}/syslinux/ 103 install -d ${D}${datadir}/syslinux/
@@ -107,19 +107,19 @@ do_install_class-target() {
107 107
108PACKAGES += "${PN}-nomtools ${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc" 108PACKAGES += "${PN}-nomtools ${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc"
109 109
110RDEPENDS_${PN} += "mtools" 110RDEPENDS:${PN} += "mtools"
111RDEPENDS_${PN}-nomtools += "libext2fs" 111RDEPENDS:${PN}-nomtools += "libext2fs"
112RDEPENDS_${PN}-misc += "perl" 112RDEPENDS:${PN}-misc += "perl"
113 113
114FILES_${PN} = "${bindir}/syslinux" 114FILES:${PN} = "${bindir}/syslinux"
115FILES_${PN}-nomtools = "${bindir}/syslinux-nomtools" 115FILES:${PN}-nomtools = "${bindir}/syslinux-nomtools"
116FILES_${PN}-extlinux = "${sbindir}/extlinux" 116FILES:${PN}-extlinux = "${sbindir}/extlinux"
117FILES_${PN}-mbr = "${datadir}/${BPN}/mbr.bin" 117FILES:${PN}-mbr = "${datadir}/${BPN}/mbr.bin"
118FILES_${PN}-chain = "${datadir}/${BPN}/chain.c32" 118FILES:${PN}-chain = "${datadir}/${BPN}/chain.c32"
119FILES_${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin" 119FILES:${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin"
120FILES_${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0" 120FILES:${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0"
121FILES_${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld" 121FILES:${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld"
122FILES_${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a" 122FILES:${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a"
123FILES_${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*" 123FILES:${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*"
124 124
125BBCLASSEXTEND = "native nativesdk" 125BBCLASSEXTEND = "native nativesdk"