summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/syslinux/syslinux_6.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/syslinux/syslinux_6.01.bb')
-rw-r--r--meta/recipes-devtools/syslinux/syslinux_6.01.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.01.bb b/meta/recipes-devtools/syslinux/syslinux_6.01.bb
new file mode 100644
index 0000000000..4438ea8330
--- /dev/null
+++ b/meta/recipes-devtools/syslinux/syslinux_6.01.bb
@@ -0,0 +1,68 @@
1DESCRIPTION = "A multi-purpose linux bootloader"
2HOMEPAGE = "http://syslinux.zytor.com/"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
5 file://README;beginline=35;endline=41;md5=558f2c71cb1fb9ba511ccd4858e48e8a"
6
7# If you really want to run syslinux, you need mtools. We just want the
8# ldlinux.* stuff for now, so skip mtools-native
9DEPENDS = "nasm-native util-linux"
10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/boot/syslinux/6.xx/syslinux-${PV}.tar.bz2"
12
13SRC_URI[md5sum] = "6945ee89e29119d459baed4937bbc534"
14SRC_URI[sha256sum] = "83a04cf81e6a46b80ee5a321926eea095af3498b04317e3674b46c125c7a5b43"
15
16COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
17# Don't let the sanity checker trip on the 32 bit real mode BIOS binaries
18INSANE_SKIP_${PN}-misc = "arch"
19INSANE_SKIP_${PN}-chain = "arch"
20
21EXTRA_OEMAKE = " \
22 BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \
23 DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \
24"
25# syslinux uses $LD for linking, strip `-Wl,' so it can work
26export LDFLAGS = "`echo $LDFLAGS | sed 's/-Wl,//g'`"
27
28do_configure() {
29 # drop win32 targets or build fails
30 sed -e 's,win32/\S*,,g' -i Makefile
31
32 # clean installer executables included in source tarball
33 oe_runmake clean firmware="efi32" EFIINC="${includedir}"
34 # NOTE: There is a temporary work around above to specify
35 # the efi32 as the firmware else the pre-built bios
36 # files get erased contrary to the doc/distib.txt
37 # In the future this should be "bios" and not "efi32".
38}
39
40do_compile() {
41 # Rebuild only the installer; keep precompiled bootloaders
42 # as per author's request (doc/distrib.txt)
43 oe_runmake CC="${CC} ${CFLAGS}" LDFLAGS="${LDFLAGS}" firmware="bios" installer
44}
45
46do_install() {
47 oe_runmake install INSTALLROOT="${D}" firmware="bios"
48
49 install -d ${D}${datadir}/syslinux/
50 install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/
51 install -m 644 ${S}/bios/core/ldlinux.bss ${D}${datadir}/syslinux/
52}
53
54PACKAGES += "${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc"
55
56RDEPENDS_${PN} += "mtools"
57
58FILES_${PN} = "${bindir}/syslinux"
59FILES_${PN}-extlinux = "${sbindir}/extlinux"
60FILES_${PN}-mbr = "${datadir}/${BPN}/mbr.bin"
61FILES_${PN}-chain = "${datadir}/${BPN}/chain.c32"
62FILES_${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin"
63FILES_${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0"
64FILES_${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld"
65FILES_${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a"
66FILES_${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*"
67
68BBCLASSEXTEND = "native"