summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/syslinux/syslinux_3.86.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/syslinux/syslinux_3.86.bb')
-rw-r--r--meta/recipes-devtools/syslinux/syslinux_3.86.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_3.86.bb b/meta/recipes-devtools/syslinux/syslinux_3.86.bb
new file mode 100644
index 0000000000..5edbd24086
--- /dev/null
+++ b/meta/recipes-devtools/syslinux/syslinux_3.86.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "A multi-purpose linux bootloader"
2HOMEPAGE = "http://syslinux.zytor.com/"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
5 file://README;beginline=28;endline=34;md5=a4607efd4a6392017186d08099e7d546"
6
7# If you really want to run syslinux, you need mtools. We just want the
8# ldlinux.* stuff for now, so skip mtools-native
9DEPENDS = "nasm-native"
10PR = "r1"
11
12SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 \
13 file://cross-build.patch"
14
15COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)'
16
17EXTRA_OEMAKE = " \
18 BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \
19 DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \
20"
21# syslinux uses $LD for linking, strip `-Wl,' so it can work
22export LDFLAGS = "`echo $LDFLAGS | sed 's/-Wl,//g'`"
23
24do_configure() {
25 # drop win32 targets or build fails
26 sed -e 's,win32/\S*,,g' -i Makefile
27
28 # clean installer executables included in source tarball
29 oe_runmake clean
30}
31
32do_compile() {
33 # Rebuild only the installer; keep precompiled bootloaders
34 # as per author's request (doc/distrib.txt)
35 oe_runmake CC="${CC}" installer
36}
37
38do_install() {
39 oe_runmake install INSTALLROOT="${D}"
40
41 install -d ${D}${libdir}/syslinux/
42 install -m 644 ${S}/core/ldlinux.sys ${D}${libdir}/syslinux/
43 install -m 644 ${S}/core/ldlinux.bss ${D}${libdir}/syslinux/
44}
45
46BBCLASSEXTEND = "native"