summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/subversion/subversion_1.6.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/subversion/subversion_1.6.13.bb')
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.6.13.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion_1.6.13.bb b/meta/recipes-devtools/subversion/subversion_1.6.13.bb
new file mode 100644
index 0000000000..bcdb6c22ea
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion_1.6.13.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "The Subversion (svn) client"
2SECTION = "console/network"
3DEPENDS = "apr-util neon"
4RDEPENDS = "neon"
5LICENSE = "Apache BSD"
6HOMEPAGE = "http://subversion.tigris.org"
7
8PR = "r0"
9
10SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11 file://disable-revision-install.patch;patch=1 \
12 file://neon-detection.patch;patch=1 \
13 file://libtool2.patch;patch=1"
14
15SRC_URI[md5sum] = "7ae1c827689f21cf975804005be30aeb"
16SRC_URI[sha256sum] = "3a30327bdb04109f369586196ee4a6993cdab2cfa85c3134549f02c229bf0d15"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=2a69fef414e2cb907b4544298569300b"
19
20EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
21 --without-berkeley-db --without-apxs --without-apache \
22 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
23 --with-apr-util=${STAGING_BINDIR_CROSS}"
24
25inherit autotools
26
27export LDFLAGS += " -L${STAGING_LIBDIR} "
28
29acpaths = "-I build/ -I build/ac-macros/"
30
31do_configure_prepend () {
32 rm -f ${S}/libtool
33 rm -f ${S}/build/libtool.m4
34 sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
35}