summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/subversion/subversion_1.5.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/subversion/subversion_1.5.5.bb')
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.5.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion_1.5.5.bb b/meta/recipes-devtools/subversion/subversion_1.5.5.bb
new file mode 100644
index 0000000000..8adac8a6fa
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion_1.5.5.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "The Subversion (svn) client"
2SECTION = "console/network"
3DEPENDS = "apr-util neon"
4RDEPENDS = "neon"
5LICENSE = "Apache BSD"
6HOMEPAGE = "http://subversion.tigris.org"
7
8PR = "r6"
9
10SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11 file://disable-revision-install.patch;patch=1 \
12 file://neon-detection.patch;patch=1 \
13 file://libtool2.patch;patch=1"
14
15EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
16 --without-berkeley-db --without-apxs --without-apache \
17 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
18 --with-apr-util=${STAGING_BINDIR_CROSS}"
19
20inherit autotools
21
22export LDFLAGS += " -L${STAGING_LIBDIR} "
23
24acpaths = "-I build/ -I build/ac-macros/"
25
26do_configure_prepend () {
27 rm -f ${S}/libtool
28 rm -f ${S}/build/libtool.m4
29}