diff options
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.9.bb')
-rw-r--r-- | meta/recipes-devtools/strace/strace_4.9.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.9.bb b/meta/recipes-devtools/strace/strace_4.9.bb new file mode 100644 index 0000000000..f64c6ecac4 --- /dev/null +++ b/meta/recipes-devtools/strace/strace_4.9.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | SUMMARY = "System call tracing tool" | ||
2 | HOMEPAGE = "http://strace.sourceforge.net" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \ | ||
8 | file://git-version-gen \ | ||
9 | file://strace-add-configure-options.patch \ | ||
10 | file://Makefile-ptest.patch \ | ||
11 | file://run-ptest \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "885eafadb10f6c60464a266d3929a2a4" | ||
15 | SRC_URI[sha256sum] = "095bfea5c540b91d297ccac73b21b92fd54a24599fd70395db87ff9eb7fd6f65" | ||
16 | |||
17 | inherit autotools ptest | ||
18 | RDEPENDS_${PN}-ptest += "make coreutils grep gawk" | ||
19 | |||
20 | PACKAGECONFIG_class-target ?= "libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}" | ||
21 | |||
22 | PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio" | ||
23 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl" | ||
24 | |||
25 | export INCLUDES = "-I. -I./linux" | ||
26 | |||
27 | TESTDIR = "tests" | ||
28 | |||
29 | do_configure_prepend() { | ||
30 | cp ${WORKDIR}/git-version-gen ${S} | ||
31 | } | ||
32 | |||
33 | do_install_append() { | ||
34 | # We don't ship strace-graph here because it needs perl | ||
35 | rm ${D}${bindir}/strace-graph | ||
36 | } | ||
37 | |||
38 | do_compile_ptest() { | ||
39 | oe_runmake -C ${TESTDIR} buildtest-TESTS | ||
40 | } | ||
41 | |||
42 | do_install_ptest() { | ||
43 | oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR} | ||
44 | } | ||
45 | |||
46 | BBCLASSEXTEND = "native" | ||