summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.22.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.22.bb16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.22.bb b/meta/recipes-devtools/strace/strace_4.22.bb
index 947b3f7bf6..99691f87c3 100644
--- a/meta/recipes-devtools/strace/strace_4.22.bb
+++ b/meta/recipes-devtools/strace/strace_4.22.bb
@@ -14,21 +14,13 @@ SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
14 file://mips-SIGEMT.patch \ 14 file://mips-SIGEMT.patch \
15 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \ 15 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
16 file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \ 16 file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \
17 file://0001-linux-arm-raw_syscall.h-avoid-r7-specified-register-.patch \
17 " 18 "
18SRC_URI[md5sum] = "7a2a7d7715da6e6834bc65bd09bace1c" 19SRC_URI[md5sum] = "7a2a7d7715da6e6834bc65bd09bace1c"
19SRC_URI[sha256sum] = "068cd09264c95e4d591bbcd3ea08f99a693ed8663cd5169b0fdad72eb5bdb39d" 20SRC_URI[sha256sum] = "068cd09264c95e4d591bbcd3ea08f99a693ed8663cd5169b0fdad72eb5bdb39d"
20 21
21inherit autotools ptest bluetooth 22inherit autotools ptest bluetooth
22 23
23EXTRA_OECONF += "--enable-mpers=no"
24
25CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
26# otherwise strace-4.22/tests/inject-nf.c fails to build as discussed here:
27# http://lists.openembedded.org/pipermail/openembedded-core/2018-May/150647.html
28DEBUG_OPTIMIZATION_remove = "${@bb.utils.contains('PTEST_ENABLED', '1', '-fno-omit-frame-pointer', '', d)}"
29
30RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
31
32PACKAGECONFIG_class-target ??= "\ 24PACKAGECONFIG_class-target ??= "\
33 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ 25 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
34" 26"
@@ -36,6 +28,10 @@ PACKAGECONFIG_class-target ??= "\
36PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}" 28PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
37PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" 29PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
38 30
31EXTRA_OECONF += "--enable-mpers=no"
32
33CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
34
39TESTDIR = "tests" 35TESTDIR = "tests"
40 36
41do_install_append() { 37do_install_append() {
@@ -61,5 +57,7 @@ do_install_ptest() {
61 ${D}/${PTEST_PATH}/${TESTDIR}/Makefile 57 ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
62} 58}
63 59
60RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
61
64BBCLASSEXTEND = "native" 62BBCLASSEXTEND = "native"
65TOOLCHAIN = "gcc" 63TOOLCHAIN = "gcc"