summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.22.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.22.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.22.bb b/meta/recipes-devtools/strace/strace_4.22.bb
new file mode 100644
index 0000000000..196c9d8587
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.22.bb
@@ -0,0 +1,62 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.io"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6ddb91734b9c705f3e87362e97e5f64b"
6
7SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
14 file://mips-SIGEMT.patch \
15 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
16 file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \
17 "
18SRC_URI[md5sum] = "7a2a7d7715da6e6834bc65bd09bace1c"
19SRC_URI[sha256sum] = "068cd09264c95e4d591bbcd3ea08f99a693ed8663cd5169b0fdad72eb5bdb39d"
20
21inherit autotools ptest bluetooth
22
23EXTRA_OECONF += "--enable-mpers=no"
24
25CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext"
26
27RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
28
29PACKAGECONFIG_class-target ??= "\
30 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
31"
32
33PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
34PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
35
36TESTDIR = "tests"
37
38do_install_append() {
39 # We don't ship strace-graph here because it needs perl
40 rm ${D}${bindir}/strace-graph
41}
42
43do_compile_ptest() {
44 oe_runmake -C ${TESTDIR} buildtest-TESTS
45}
46
47do_install_ptest() {
48 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
49 sed -i -e '/^src/s/strace.*[1-9]/ptest/' \
50 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
51 -e 's|${DEBUG_PREFIX_MAP}||g' \
52 -e 's:${HOSTTOOLS_DIR}/::g' \
53 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
54 -e 's:${RECIPE_SYSROOT}::g' \
55 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
56 -e '/^DEB_CHANGELOGTIME/d' \
57 -e '/^RPM_CHANGELOGTIME/d' \
58 ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
59}
60
61BBCLASSEXTEND = "native"
62TOOLCHAIN = "gcc"