diff options
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.20.bb')
-rw-r--r-- | meta/recipes-devtools/strace/strace_4.20.bb | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.20.bb b/meta/recipes-devtools/strace/strace_4.20.bb new file mode 100644 index 0000000000..d5df25eba8 --- /dev/null +++ b/meta/recipes-devtools/strace/strace_4.20.bb | |||
@@ -0,0 +1,59 @@ | |||
1 | SUMMARY = "System call tracing tool" | ||
2 | HOMEPAGE = "http://strace.sourceforge.net" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=f132b4d2adfccc63da4139a609367711" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \ | ||
8 | file://disable-git-version-gen.patch \ | ||
9 | file://more-robust-test-for-m32-mx32-compile-support.patch \ | ||
10 | file://update-gawk-paths.patch \ | ||
11 | file://Makefile-ptest.patch \ | ||
12 | file://run-ptest \ | ||
13 | file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \ | ||
14 | file://mips-SIGEMT.patch \ | ||
15 | file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \ | ||
16 | file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \ | ||
17 | " | ||
18 | |||
19 | SRC_URI[md5sum] = "f2271ab0fac49ebee9cbd7f3469227cb" | ||
20 | SRC_URI[sha256sum] = "5bf3148dd17306a42566f7da17368fdd781afa147db05ea63a4ca2b50f58c523" | ||
21 | |||
22 | inherit autotools ptest bluetooth | ||
23 | |||
24 | RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed" | ||
25 | |||
26 | PACKAGECONFIG_class-target ??= "\ | ||
27 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ | ||
28 | " | ||
29 | |||
30 | PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}" | ||
31 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" | ||
32 | |||
33 | TESTDIR = "tests" | ||
34 | |||
35 | do_install_append() { | ||
36 | # We don't ship strace-graph here because it needs perl | ||
37 | rm ${D}${bindir}/strace-graph | ||
38 | } | ||
39 | |||
40 | do_compile_ptest() { | ||
41 | oe_runmake -C ${TESTDIR} buildtest-TESTS | ||
42 | } | ||
43 | |||
44 | do_install_ptest() { | ||
45 | oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR} | ||
46 | sed -i -e '/^src/s/strace.*[1-9]/ptest/' \ | ||
47 | -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ | ||
48 | -e 's|${DEBUG_PREFIX_MAP}||g' \ | ||
49 | -e 's:${HOSTTOOLS_DIR}/::g' \ | ||
50 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ | ||
51 | -e 's:${RECIPE_SYSROOT}::g' \ | ||
52 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \ | ||
53 | -e '/^DEB_CHANGELOGTIME/d' \ | ||
54 | -e '/^RPM_CHANGELOGTIME/d' \ | ||
55 | ${D}/${PTEST_PATH}/${TESTDIR}/Makefile | ||
56 | } | ||
57 | |||
58 | BBCLASSEXTEND = "native" | ||
59 | TOOLCHAIN = "gcc" | ||