diff options
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.18.bb')
-rw-r--r-- | meta/recipes-devtools/strace/strace_4.18.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.18.bb b/meta/recipes-devtools/strace/strace_4.18.bb new file mode 100644 index 0000000000..bbb82a9d84 --- /dev/null +++ b/meta/recipes-devtools/strace/strace_4.18.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | SUMMARY = "System call tracing tool" | ||
2 | HOMEPAGE = "http://strace.sourceforge.net" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=f132b4d2adfccc63da4139a609367711" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \ | ||
8 | file://disable-git-version-gen.patch \ | ||
9 | file://more-robust-test-for-m32-mx32-compile-support.patch \ | ||
10 | file://update-gawk-paths.patch \ | ||
11 | file://Makefile-ptest.patch \ | ||
12 | file://run-ptest \ | ||
13 | file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \ | ||
14 | file://mips-SIGEMT.patch \ | ||
15 | file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "3579b3266bb096cebaefbe2cdb1a3a78" | ||
19 | SRC_URI[sha256sum] = "89ad887c1e6226bdbca8da31d589cadea4be0744b142eb47b768086c937fca08" | ||
20 | |||
21 | inherit autotools ptest bluetooth | ||
22 | |||
23 | RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed" | ||
24 | |||
25 | PACKAGECONFIG_class-target ??= "\ | ||
26 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ | ||
27 | " | ||
28 | |||
29 | PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}" | ||
30 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" | ||
31 | |||
32 | TESTDIR = "tests" | ||
33 | |||
34 | do_install_append() { | ||
35 | # We don't ship strace-graph here because it needs perl | ||
36 | rm ${D}${bindir}/strace-graph | ||
37 | } | ||
38 | |||
39 | do_compile_ptest() { | ||
40 | oe_runmake -C ${TESTDIR} buildtest-TESTS | ||
41 | } | ||
42 | |||
43 | do_install_ptest() { | ||
44 | oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR} | ||
45 | sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile | ||
46 | } | ||
47 | |||
48 | BBCLASSEXTEND = "native" | ||
49 | TOOLCHAIN = "gcc" | ||