summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.14.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.14.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.14.bb b/meta/recipes-devtools/strace/strace_4.14.bb
new file mode 100644
index 0000000000..452925c7ea
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.14.bb
@@ -0,0 +1,49 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://use-asm-sgidefs.h.patch \
12 file://Makefile-ptest.patch \
13 file://run-ptest \
14 file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
15 file://mips-SIGEMT.patch \
16 "
17
18SRC_URI[md5sum] = "1e39b5f7583256d7dc21170b9da529ae"
19SRC_URI[sha256sum] = "5bed5110b243dce6864bedba269446c18c8c63f553cdd7fd4f808d89a764712f"
20
21inherit autotools ptest bluetooth
22
23RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
24
25PACKAGECONFIG_class-target ??= "\
26 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
27"
28
29PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
30PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
31
32TESTDIR = "tests"
33
34do_install_append() {
35 # We don't ship strace-graph here because it needs perl
36 rm ${D}${bindir}/strace-graph
37}
38
39do_compile_ptest() {
40 oe_runmake -C ${TESTDIR} buildtest-TESTS
41}
42
43do_install_ptest() {
44 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
45 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
46}
47
48BBCLASSEXTEND = "native"
49TOOLCHAIN = "gcc"