summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.11.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.11.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.11.bb b/meta/recipes-devtools/strace/strace_4.11.bb
new file mode 100644
index 0000000000..a72a1f9c24
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.11.bb
@@ -0,0 +1,44 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 "
14
15SRC_URI[md5sum] = "a15d2555a7febb56d00c6e1a51c655dc"
16SRC_URI[sha256sum] = "e86a5f6cd8f941f67f3e4b28f4e60f3d9185c951cf266404533210a2e5cd8152"
17
18inherit autotools ptest bluetooth
19
20RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
21
22PACKAGECONFIG_class-target ??= "\
23 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
24"
25
26PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
27PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
28
29TESTDIR = "tests"
30
31do_install_append() {
32 # We don't ship strace-graph here because it needs perl
33 rm ${D}${bindir}/strace-graph
34}
35
36do_compile_ptest() {
37 oe_runmake -C ${TESTDIR} buildtest-TESTS
38}
39
40do_install_ptest() {
41 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
42}
43
44BBCLASSEXTEND = "native"