summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
new file mode 100644
index 0000000000..e0c69ab127
--- /dev/null
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
@@ -0,0 +1,38 @@
1# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
5LICENSE = "GPL-2 & PD"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
8 "
9DEPENDS = "attr zlib xz"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \
12 http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
13 "
14
15SRC_URI[squashfs.md5sum] = "d92ab59aabf5173f2a59089531e30dbf"
16SRC_URI[squashfs.sha256sum] = "0d605512437b1eb800b4736791559295ee5f60177e102e4d4ccd0ee241a5f3f6"
17
18SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
19SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
20
21S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
22
23# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
24# the -e causes problems as CFLAGS is modified in the Makefile, so
25# we redefine EXTRA_OEMAKE here
26EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1"
27
28do_compile() {
29 oe_runmake mksquashfs
30}
31do_install () {
32 install -d ${D}${sbindir}
33 install -m 0755 mksquashfs ${D}${sbindir}/
34}
35
36ARM_INSTRUCTION_SET = "arm"
37
38BBCLASSEXTEND = "native"