summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb
new file mode 100644
index 0000000000..57400cdda0
--- /dev/null
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb
@@ -0,0 +1,42 @@
1# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
5LICENSE = "GPL-2 & PD"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
7 file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
8 "
9DEPENDS = "attr zlib xz"
10PR = "r2"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \
13 http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
14 "
15SRC_URI += "file://squashfs-4.2-fix-CVE-2012-4024.patch \
16 file://squashfs-add-a-commment-and-fix-some-other-comments.patch \
17 file://squashfs-fix-open-file-limit.patch \
18 file://squashfs-4.2-fix-CVE-2012-4025.patch \
19 "
20SRC_URI[squashfs.md5sum] = "1b7a781fb4cf8938842279bd3e8ee852"
21SRC_URI[squashfs.sha256sum] = "d9e0195aa922dbb665ed322b9aaa96e04a476ee650f39bbeadb0d00b24022e96"
22SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
23SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
24
25S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
26
27# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
28# the -e causes problems as CFLAGS is modified in the Makefile, so
29# we redefine EXTRA_OEMAKE here
30EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1"
31
32do_compile() {
33 oe_runmake mksquashfs
34}
35do_install () {
36 install -d ${D}${sbindir}
37 install -m 0755 mksquashfs ${D}${sbindir}/
38}
39
40ARM_INSTRUCTION_SET = "arm"
41
42BBCLASSEXTEND = "native"