summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb')
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
index 2c8d874eb7..af7e104274 100644
--- a/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
+++ b/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
@@ -13,7 +13,7 @@ LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://LICENSE-GPLv2;md5=ab8a50abe86dfc859e148baae043c89b" 13LIC_FILES_CHKSUM = "file://LICENSE-GPLv2;md5=ab8a50abe86dfc859e148baae043c89b"
14SECTION = "base" 14SECTION = "base"
15 15
16PR = "r0" 16PR = "r1"
17 17
18require sgml-common_${PV}.bb 18require sgml-common_${PV}.bb
19inherit native 19inherit native
@@ -21,6 +21,8 @@ inherit native
21S = "${WORKDIR}/sgml-common-${PV}" 21S = "${WORKDIR}/sgml-common-${PV}"
22 22
23SYSROOT_PREPROCESS_FUNCS += "sgml_common_native_mangle" 23SYSROOT_PREPROCESS_FUNCS += "sgml_common_native_mangle"
24SSTATEPOSTINSTFUNCS += "sgml_common_sstate_postinst"
25
24 26
25do_install_append() { 27do_install_append() {
26 # install-catalog script contains hard-coded references to 28 # install-catalog script contains hard-coded references to
@@ -46,3 +48,17 @@ sgml_common_native_mangle () {
46 # Remove ${D} path from catalog file created by install-catalog script 48 # Remove ${D} path from catalog file created by install-catalog script
47 sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/catalog 49 sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/catalog
48} 50}
51
52sgml_common_sstate_postinst() {
53 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
54 then
55 if [ -e ${sysconfdir}/sgml/sgml-docbook.bak ]; then
56 for catalog in `awk '{print $2}' ${sysconfdir}/sgml/sgml-docbook.bak`; do
57 if [ ! `grep $catalog ${sysconfdir}/sgml/sgml-docbook.cat 1> /dev/null 2>&1` ]; then
58 ${bindir}/install-catalog \
59 --add ${sysconfdir}/sgml/sgml-docbook.cat $catalog
60 fi
61 done
62 fi
63 fi
64}