summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.4.4.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.4.4.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.4.4.bb b/meta/recipes-devtools/ruby/ruby_2.4.4.bb
new file mode 100644
index 0000000000..c6faea0fa0
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.4.4.bb
@@ -0,0 +1,52 @@
1require ruby.inc
2
3SRC_URI += " \
4 file://ruby-CVE-2017-9224.patch \
5 file://ruby-CVE-2017-9226.patch \
6 file://ruby-CVE-2017-9227.patch \
7 file://ruby-CVE-2017-9228.patch \
8 file://ruby-CVE-2017-9229.patch \
9 "
10
11SRC_URI[md5sum] = "d50e00ccc1c9cf450f837b92d3ed3e88"
12SRC_URI[sha256sum] = "254f1c1a79e4cc814d1e7320bc5bdd995dc57e08727d30a767664619a9c8ae5a"
13
14# it's unknown to configure script, but then passed to extconf.rb
15# maybe it's not really needed as we're hardcoding the result with
16# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
17UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
21
22PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
23PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp"
24PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
25
26EXTRA_AUTORECONF += "--exclude=aclocal"
27
28EXTRA_OECONF = "\
29 --disable-versioned-paths \
30 --disable-rpath \
31 --disable-dtrace \
32 --enable-shared \
33 --enable-load-relative \
34"
35
36do_install() {
37 oe_runmake 'DESTDIR=${D}' install
38}
39
40PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
41
42SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
43RDEPENDS_${PN}-ri-docs = "${PN}"
44FILES_${PN}-ri-docs += "${datadir}/ri"
45
46SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
47RDEPENDS_${PN}-rdoc = "${PN}"
48FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
49
50FILES_${PN} += "${datadir}/rubygems"
51
52BBCLASSEXTEND = "native"