summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.4.1.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.4.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.4.1.bb b/meta/recipes-devtools/ruby/ruby_2.4.1.bb
new file mode 100644
index 0000000000..f814da9d95
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.4.1.bb
@@ -0,0 +1,53 @@
1require ruby.inc
2
3SRC_URI += " \
4 file://ruby-CVE-2017-9224.patch \
5 file://ruby-CVE-2017-9226.patch \
6 file://ruby-CVE-2017-9227.patch \
7 file://ruby-CVE-2017-9228.patch \
8 file://ruby-CVE-2017-9229.patch \
9 file://CVE-2017-14064.patch \
10 "
11
12SRC_URI[md5sum] = "782bca562e474dd25956dd0017d92677"
13SRC_URI[sha256sum] = "a330e10d5cb5e53b3a0078326c5731888bb55e32c4abfeb27d9e7f8e5d000250"
14
15# it's unknown to configure script, but then passed to extconf.rb
16# maybe it's not really needed as we're hardcoding the result with
17# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
18UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
22
23PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
24PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
25PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
26
27EXTRA_AUTORECONF += "--exclude=aclocal"
28
29EXTRA_OECONF = "\
30 --disable-versioned-paths \
31 --disable-rpath \
32 --disable-dtrace \
33 --enable-shared \
34 --enable-load-relative \
35"
36
37do_install() {
38 oe_runmake 'DESTDIR=${D}' install
39}
40
41PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
42
43SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
44RDEPENDS_${PN}-ri-docs = "${PN}"
45FILES_${PN}-ri-docs += "${datadir}/ri"
46
47SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
48RDEPENDS_${PN}-rdoc = "${PN}"
49FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
50
51FILES_${PN} += "${datadir}/rubygems"
52
53BBCLASSEXTEND = "native"