diff options
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.3.1.bb')
-rw-r--r-- | meta/recipes-devtools/ruby/ruby_2.3.1.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.3.1.bb b/meta/recipes-devtools/ruby/ruby_2.3.1.bb new file mode 100644 index 0000000000..299383ad3e --- /dev/null +++ b/meta/recipes-devtools/ruby/ruby_2.3.1.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | require ruby.inc | ||
2 | |||
3 | SRC_URI[md5sum] = "0d896c2e7fd54f722b399f407e48a4c6" | ||
4 | SRC_URI[sha256sum] = "b87c738cb2032bf4920fef8e3864dc5cf8eae9d89d8d523ce0236945c5797dcd" | ||
5 | |||
6 | # it's unknown to configure script, but then passed to extconf.rb | ||
7 | # maybe it's not really needed as we're hardcoding the result with | ||
8 | # 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch | ||
9 | UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo" | ||
10 | |||
11 | PACKAGECONFIG ??= "" | ||
12 | PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}" | ||
13 | |||
14 | PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind" | ||
15 | PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp" | ||
16 | PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo," | ||
17 | |||
18 | EXTRA_AUTORECONF += "--exclude=aclocal" | ||
19 | |||
20 | EXTRA_OECONF = "\ | ||
21 | --disable-versioned-paths \ | ||
22 | --disable-rpath \ | ||
23 | --disable-dtrace \ | ||
24 | --enable-shared \ | ||
25 | --enable-load-relative \ | ||
26 | " | ||
27 | |||
28 | do_install() { | ||
29 | oe_runmake 'DESTDIR=${D}' install | ||
30 | } | ||
31 | |||
32 | PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc" | ||
33 | |||
34 | SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library" | ||
35 | RDEPENDS_${PN}-ri-docs = "${PN}" | ||
36 | FILES_${PN}-ri-docs += "${datadir}/ri" | ||
37 | |||
38 | SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source" | ||
39 | RDEPENDS_${PN}-rdoc = "${PN}" | ||
40 | FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc" | ||
41 | |||
42 | FILES_${PN} += "${datadir}/rubygems" | ||
43 | |||
44 | BBCLASSEXTEND = "native" | ||