summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.1.1.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.1.bb b/meta/recipes-devtools/rsync/rsync_3.1.1.bb
new file mode 100644
index 0000000000..5ff8ae8bb4
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.1.1.bb
@@ -0,0 +1,27 @@
1require rsync.inc
2
3
4SRC_URI += "file://acinclude.m4"
5
6SRC_URI[md5sum] = "43bd6676f0b404326eee2d63be3cdcfe"
7SRC_URI[sha256sum] = "7de4364fcf5fe42f3bdb514417f1c40d10bbca896abe7e7f2c581c6ea08a2621"
8
9PACKAGECONFIG ??= "acl attr"
10PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
11PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
12
13# rsync 3.0 uses configure.sh instead of configure, and
14# makefile checks the existence of configure.sh
15do_configure_prepend () {
16 rm -f ${S}/configure ${S}/configure.sh
17 cp -f ${WORKDIR}/acinclude.m4 ${S}/
18
19 # By default, if crosscompiling, rsync disables a number of
20 # capabilities, hardlinking symlinks and special files (i.e. devices)
21 export rsync_cv_can_hardlink_special=yes
22 export rsync_cv_can_hardlink_symlink=yes
23}
24
25do_configure_append () {
26 cp -f ${S}/configure ${S}/configure.sh
27}