summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.1.0.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.0.bb b/meta/recipes-devtools/rsync/rsync_3.1.0.bb
new file mode 100644
index 0000000000..72c072dae5
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.1.0.bb
@@ -0,0 +1,26 @@
1require rsync.inc
2
3
4SRC_URI += "file://acinclude.m4"
5
6SRC_URI[md5sum] = "3be148772a33224771a8d4d2a028b132"
7SRC_URI[sha256sum] = "81ca23f77fc9b957eb9845a6024f41af0ff0c619b7f38576887c63fa38e2394e"
8
9EXTRA_OECONF += "--disable-xattr-support --disable-acl-support"
10
11# rsync 3.0 uses configure.sh instead of configure, and
12# makefile checks the existence of configure.sh
13do_configure_prepend () {
14 rm -f ${S}/configure ${S}/configure.sh
15 cp -f ${WORKDIR}/acinclude.m4 ${S}/
16
17 # by default, if crosscompiling, rsync
18 # disables a number of capabilities, hardlinking
19 # symlinks and special files (ie devices)
20 export rsync_cv_can_hardlink_special=yes
21 export rsync_cv_can_hardlink_symlink=yes
22}
23
24do_configure_append () {
25 cp -f ${S}/configure ${S}/configure.sh
26}