diff options
Diffstat (limited to 'meta/recipes-devtools/rpm/rpmresolve_1.0.bb')
-rw-r--r-- | meta/recipes-devtools/rpm/rpmresolve_1.0.bb | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpmresolve_1.0.bb b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb new file mode 100644 index 0000000000..f8750e02ba --- /dev/null +++ b/meta/recipes-devtools/rpm/rpmresolve_1.0.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "OpenEmbedded RPM resolver utility" | ||
2 | DESCRIPTION = "OpenEmbedded RPM resolver - performs RPM database lookups in batches to avoid \ | ||
3 | repeated invocations of rpm on the command line." | ||
4 | DEPENDS = "rpm" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | ||
7 | PR = "r0" | ||
8 | |||
9 | SRC_URI = "file://rpmresolve.c" | ||
10 | |||
11 | S = "${WORKDIR}" | ||
12 | |||
13 | do_compile() { | ||
14 | ${CC} ${CFLAGS} -ggdb -I${STAGING_INCDIR}/rpm ${LDFLAGS} rpmresolve.c -o rpmresolve -lrpmbuild -lrpm -lrpmio -lrpmdb -lpopt | ||
15 | } | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${bindir} | ||
19 | install -m 0755 rpmresolve ${D}${bindir} | ||
20 | } | ||
21 | |||
22 | BBCLASSEXTEND = "native" | ||