summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_git.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index ea894a3470..7866314ad4 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -107,7 +107,8 @@ do_install_append_class-target() {
107} 107}
108 108
109do_install_append () { 109do_install_append () {
110 sed -i -e 's:${HOSTTOOLS_DIR}/::g' ${D}/${libdir}/rpm/macros 110 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
111 ${D}/${libdir}/rpm/macros
111 112
112 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \ 113 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
113 ${D}${libdir}/rpm/pythondistdeps.py 114 ${D}${libdir}/rpm/pythondistdeps.py
@@ -127,3 +128,11 @@ FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
127RPROVIDES_${PN} += "rpm-build" 128RPROVIDES_${PN} += "rpm-build"
128 129
129RDEPENDS_${PN} = "bash perl python3-core" 130RDEPENDS_${PN} = "bash perl python3-core"
131
132PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
133
134# Do not specify a sysroot when compiling on a target.
135rpm_package_preprocess () {
136 sed -i -e 's:--sysroot[^ ]*::g' \
137 ${PKGD}/${libdir}/rpm/macros
138}