summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.8.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.8.bb462
1 files changed, 462 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.8.bb b/meta/recipes-devtools/rpm/rpm_5.4.8.bb
new file mode 100644
index 0000000000..ac86ff3cd4
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_5.4.8.bb
@@ -0,0 +1,462 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-libs = "Libraries for manipulating RPM packages."
9DESCRIPTION_${PN}-libs = "This package contains the RPM shared libraries."
10
11SUMMARY_${PN}-dev = "Development files for manipulating RPM packages."
12DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
13development files will simplify the process of writing programs that \
14manipulate RPM packages and databases. These files are intended to \
15simplify the process of creating graphical package managers or any \
16other tools that need an intimate knowledge of RPM packages in order \
17to function."
18
19SUMMARY_${PN}-common = "Common RPM paths, scripts, documentation and configuration."
20DESCRIPTION_${PN}-common = "The rpm-common package contains paths, scripts, documentation \
21and configuration common between RPM Package Manager."
22
23SUMMARY_${PN}-build = "Scripts and executable programs used to build packages."
24DESCRIPTION_${PN}-build = "The rpm-build packagec ontains the scripts and executable programs \
25that are used to build packages using the RPM Package Manager."
26
27SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages."
28DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
29written in the Python programming language to use the interface \
30supplied by the RPM Package Manager libraries."
31
32SUMMARY_perl-module-rpm = "Perl bindings for apps which will manipulate RPM packages."
33DESCRIPTION_perl-modules-rpm = "The perl-modules-rpm package contains a module that permits applications \
34written in the Perl programming language to use the interface \
35supplied by the RPM Package Manager libraries."
36
37SUMMARY_perl-module-rpm-dev = "Development components for perl bindings"
38DESCRIPTION_perl-modules-rpm-dev = "Development items such as man pages for use with the Perl \
39language bindings."
40
41HOMEPAGE = "http://rpm5.org/"
42LICENSE = "LGPLv2.1"
43LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
44
45DEPENDS = "beecrypt bzip2 zlib db openssl elfutils expat libpcre attr acl popt ${extrarpmdeps}"
46extrarpmdeps = "python perl file"
47extrarpmdeps_virtclass-native = "python-native file-native"
48PR = "r39"
49
50# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
51# in order to extract the distribution SRPM into a format we can extract...
52SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.8-0.20120401.src.rpm;extract=rpm-5.4.8.tar.gz \
53 file://rpm-log-auto-rm.patch \
54 file://rpm-db-reduce.patch \
55 file://perfile_rpmdeps.sh \
56 file://rpm-autogen.patch \
57 file://rpm-libsql-fix.patch \
58 file://header-include-fix.patch \
59 file://rpm-platform.patch \
60 file://rpm-showrc.patch \
61 file://rpm-solvedb.patch \
62 file://rpm-tools-mtree-LDFLAGS.patch \
63 file://rpm-fileclass.patch \
64 file://rpm-canonarch.patch \
65 file://rpm-no-loopmsg.patch \
66 file://rpm-scriptletexechelper.patch \
67 file://pythondeps.sh \
68 file://rpmdeps-oecore.patch \
69 file://rpm-resolvedep.patch \
70 file://rpm-respect-arch.patch \
71 file://rpm-no-perl-urpm.patch \
72 file://rpm-macros.patch \
73 "
74
75SRC_URI[md5sum] = "424b60bf2e0a624a218440d943861644"
76SRC_URI[sha256sum] = "56eb5033d4de98c217475fb34d466d551f8912959389e7854a806e2bd9e13380"
77
78inherit autotools gettext
79
80acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
81
82# Specify the default rpm macros in terms of adjustable variables
83rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
84rpm_macros_virtclass-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
85
86# Configure values taken from rpm.spec
87WITH_BZIP2 = "--with-bzip2"
88
89WITH_XZ = "--with-xz=none"
90
91WITH_Z = "--with-zlib $WITH_BZIP2 $WITH_XZ"
92
93WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \
94 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
95 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION} \
96 --without-pythonembed \
97 "
98
99# Perl modules are not built, but they could be enabled fairly easily
100# the perl module creation and installation would need to be patched.
101# (currently has host perl contamination issues)
102#WITH_PERL = " --with-perl --without-perlembed"
103WITH_PERL = " --without-perl --without-perl-urpm"
104
105WITH_PERL_virtclass-native = " --without-perl --without-perl-urpm"
106
107WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated --without-sqlite"
108
109WITH_CRYPTO = "--with-beecrypt --with-openssl --without-nss --without-gcrypt"
110
111WITH_KEYUTILS = "--without-keyutils"
112WITH_LIBELF = "--with-libelf"
113WITH_SELINUX = "--without-selinux --without-sepol --without-semanage"
114#WITH_NEON = "--with-neon=internal --without-libproxy --with-expat --without-gssapi"
115WITH_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi"
116
117EXTRA_OECONF = "--verbose \
118 --sysconfdir=/etc \
119 ${WITH_DB} \
120 ${WITH_Z} \
121 --with-file \
122 --with-path-magic=%{_usrlibrpm}/../../share/misc/magic.mgc \
123 --without-lua \
124 --without-tcl \
125 --with-syck=internal \
126 --without-readline \
127 --without-augeas \
128 ${WITH_CRYPTO} \
129 --without-libtasn1 \
130 --without-pakchois \
131 --without-gnutls \
132 ${WITH_NEON} \
133 --with-pcre \
134 --enable-utf8 \
135 --without-uuid \
136 --with-attr \
137 --with-acl \
138 --without-xar \
139 --with-popt=external \
140 ${WITH_KEYUTILS} \
141 --with-pthreads \
142 ${WITH_LIBELF} \
143 --without-cudf \
144 --without-ficl \
145 --without-aterm \
146 --without-nix \
147 --without-bash \
148 --without-rc \
149 --without-js \
150 --without-gpsee \
151 ${WITH_PYTHON} \
152 ${WITH_PERL} \
153 --without-ruby \
154 --without-squirrel \
155 --with-build-extlibdep \
156 --with-build-maxextlibdep \
157 --without-valgrind \
158 --without-xz \
159 --disable-openmp \
160 --enable-build-pic \
161 --enable-build-versionscript \
162 --enable-build-warnings \
163 --enable-build-debug \
164 --enable-maintainer-mode \
165 --with-path-macros=${rpm_macros} \
166 --with-path-lib=${libdir}/rpm \
167 --with-bugreport=http://bugzilla.yoctoproject.org \
168 --program-prefix="
169
170CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY"
171
172PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-libs ${PN}-dev ${PN}-staticdev ${PN}-common ${PN}-build python-rpm-dbg python-rpm-staticdev python-rpm perl-module-rpm perl-module-rpm-dev ${PN}-locale"
173
174SOLIBS = "5.4.so"
175
176# Based on %files section in the rpm.spec
177
178FILES_${PN} = "${bindir}/rpm \
179 ${bindir}/rpmconstant \
180 ${libdir}/rpm/rpm.* \
181 ${libdir}/rpm/tgpg \
182 ${libdir}/rpm/macros \
183 ${libdir}/rpm/rpmpopt \
184 ${libdir}/rpm/rpmdb_loadcvt \
185 ${libdir}/rpm/rpm2cpio \
186 ${libdir}/rpm/vcheck \
187 ${libdir}/rpm/helpers \
188 ${libdir}/rpm/qf \
189 ${libdir}/rpm/cpuinfo.yaml \
190 ${libdir}/rpm/bin/mtree \
191 ${libdir}/rpm/bin/rpmkey \
192 ${libdir}/rpm/bin/rpmrepo \
193 ${libdir}/rpm/bin/rpmspecdump \
194 ${libdir}/rpm/bin/wget \
195 /var/lib/rpm \
196 "
197
198# ${libdir}/rpm/magic
199# ${libdir}/rpm/magic.mgc
200# ${libdir}/rpm/magic.mime
201# ${libdir}/rpm/magic.mime.mgc
202# ${libdir}/rpm/bin/db_*
203# ${libdir}/rpm/bin/grep
204
205FILES_${PN}-dbg += "${libdir}/rpm/.debug \
206 ${libdir}/rpm/bin/.debug \
207 "
208
209FILES_${PN}-common = "${bindir}/rpm2cpio \
210 ${bindir}/gendiff \
211 /etc/rpm \
212 /var/spool/repackage \
213 "
214
215FILES_${PN}-libs = "${libdir}/librpm-*.so \
216 ${libdir}/librpmconstant-*.so \
217 ${libdir}/librpmdb-*.so \
218 ${libdir}/librpmio-*.so \
219 ${libdir}/librpmmisc-*.so \
220 ${libdir}/librpmbuild-*.so \
221 "
222
223###%{_rpmhome}/lib/libxar.so.*
224###%{_rpmhome}/lib/libjs.so.*
225###%{_rpmhome}/lib/librpmjsm.so.*
226###%{_rpmhome}/lib/rpmjsm.so
227
228
229FILES_${PN}-build = "${prefix}/src/rpm \
230 ${bindir}/rpmbuild \
231 ${libdir}/rpm/brp-* \
232 ${libdir}/rpm/check-files \
233 ${libdir}/rpm/cross-build \
234 ${libdir}/rpm/find-debuginfo.sh \
235 ${libdir}/rpm/find-lang.sh \
236 ${libdir}/rpm/find-prov.pl \
237 ${libdir}/rpm/find-provides.perl \
238 ${libdir}/rpm/find-req.pl \
239 ${libdir}/rpm/find-requires.perl \
240 ${libdir}/rpm/getpo.sh \
241 ${libdir}/rpm/http.req \
242 ${libdir}/rpm/javadeps.sh \
243 ${libdir}/rpm/mono-find-provides \
244 ${libdir}/rpm/mono-find-requires \
245 ${libdir}/rpm/executabledeps.sh \
246 ${libdir}/rpm/libtooldeps.sh \
247 ${libdir}/rpm/osgideps.pl \
248 ${libdir}/rpm/perldeps.pl \
249 ${libdir}/rpm/perl.prov \
250 ${libdir}/rpm/perl.req \
251 ${libdir}/rpm/php.prov \
252 ${libdir}/rpm/php.req \
253 ${libdir}/rpm/pkgconfigdeps.sh \
254 ${libdir}/rpm/pythondeps.sh \
255 ${libdir}/rpm/bin/debugedit \
256 ${libdir}/rpm/bin/rpmcache \
257 ${libdir}/rpm/bin/rpmcmp \
258 ${libdir}/rpm/bin/rpmdeps \
259 ${libdir}/rpm/bin/rpmdeps-oecore \
260 ${libdir}/rpm/bin/rpmdigest \
261 ${libdir}/rpm/bin/abi-compliance-checker.pl \
262 ${libdir}/rpm/bin/api-sanity-autotest.pl \
263 ${libdir}/rpm/bin/chroot \
264 ${libdir}/rpm/bin/cp \
265 ${libdir}/rpm/bin/dbsql \
266 ${libdir}/rpm/bin/find \
267 ${libdir}/rpm/bin/install-sh \
268 ${libdir}/rpm/bin/lua \
269 ${libdir}/rpm/bin/luac \
270 ${libdir}/rpm/bin/mkinstalldirs \
271 ${libdir}/rpm/bin/rpmlua \
272 ${libdir}/rpm/bin/rpmluac \
273 ${libdir}/rpm/bin/sqlite3 \
274 ${libdir}/rpm/lib/liblua.a \
275 ${libdir}/rpm/lib/liblua.la \
276 ${libdir}/rpm/macros.d/cmake \
277 ${libdir}/rpm/macros.d/java \
278 ${libdir}/rpm/macros.d/libtool \
279 ${libdir}/rpm/macros.d/mandriva \
280 ${libdir}/rpm/macros.d/mono \
281 ${libdir}/rpm/macros.d/perl \
282 ${libdir}/rpm/macros.d/php \
283 ${libdir}/rpm/macros.d/pkgconfig \
284 ${libdir}/rpm/macros.d/python \
285 ${libdir}/rpm/macros.d/ruby \
286 ${libdir}/rpm/macros.d/selinux \
287 ${libdir}/rpm/macros.d/tcl \
288 ${libdir}/rpm/macros.rpmbuild \
289 ${libdir}/rpm/u_pkg.sh \
290 ${libdir}/rpm/vpkg-provides.sh \
291 ${libdir}/rpm/vpkg-provides2.sh \
292 ${libdir}/rpm/perfile_rpmdeps.sh \
293 "
294RDEPENDS_${PN}-build = "file"
295
296#%rpmattr %{_rpmhome}/gem_helper.rb
297#%rpmattr %{_rpmhome}/symclash.*
298
299FILES_python-rpm-dbg = "${libdir}/python*/rpm/.debug/_*"
300FILES_python-rpm-staticdev = "${libdir}/python*/rpm/*.a"
301FILES_python-rpm = "${libdir}/python*/rpm"
302
303FILES_perl-module-rpm = "${libdir}/perl/*/* \
304 "
305
306FILES_perl-module-rpm-dev = "${prefix}/share/man/man3/RPM* \
307 "
308
309FILES_${PN}-dev = "${includedir}/rpm \
310 ${libdir}/librpm.la \
311 ${libdir}/librpm.so \
312 ${libdir}/librpmconstant.la \
313 ${libdir}/librpmconstant.so \
314 ${libdir}/librpmdb.la \
315 ${libdir}/librpmdb.so \
316 ${libdir}/librpmio.la \
317 ${libdir}/librpmio.so \
318 ${libdir}/librpmmisc.la \
319 ${libdir}/librpmmisc.so \
320 ${libdir}/librpmbuild.la \
321 ${libdir}/librpmbuild.so \
322 ${libdir}/pkgconfig/rpm.pc \
323 "
324
325FILES_${PN}-staticdev = " \
326 ${libdir}/librpm.a \
327 ${libdir}/librpmconstant.a \
328 ${libdir}/librpmdb.a \
329 ${libdir}/librpmio.a \
330 ${libdir}/librpmmisc.a \
331 ${libdir}/librpmbuild.a \
332 "
333
334###%{_rpmhome}/lib/libxar.a
335###%{_rpmhome}/lib/libxar.la
336###%{_rpmhome}/lib/libxar.so
337###%{_rpmhome}/lib/libjs.a
338###%{_rpmhome}/lib/libjs.la
339###%{_rpmhome}/lib/libjs.so
340###%{_rpmhome}/lib/librpmjsm.a
341###%{_rpmhome}/lib/librpmjsm.la
342###%{_rpmhome}/lib/librpmjsm.so
343
344do_configure() {
345 # Disable tests!
346 echo "all:" > tests/Makefile.am
347
348 ./autogen.sh
349
350 export varprefix=${localstatedir}
351 oe_runconf
352}
353
354do_install_append() {
355 sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
356 sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
357 sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros
358 sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros
359 sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
360
361 # Enable Debian style arbitrary tags...
362 sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros
363
364 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
365 install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
366
367 # Remove unpackaged files (based on list in rpm.spec)
368 rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm}
369
370 rm -f ${D}/${mandir}/man8/rpmcache.8*
371 rm -f ${D}/${mandir}/man8/rpmgraph.8*
372 rm -f ${D}/${mandir}/*/man8/rpmcache.8*
373 rm -f ${D}/${mandir}/*/man8/rpmgraph.8*
374 rm -rf ${D}/${mandir}/{fr,ko}
375
376 rm -f ${D}/${includedir}/popt.h
377 rm -f ${D}/${libdir}/libpopt.*
378 rm -f ${D}/${libdir}/pkgconfig/popt.pc
379 rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo
380 rm -f ${D}/${mandir}/man3/popt.3
381
382 rm -f ${D}/${mandir}/man1/xar.1*
383 rm -f ${D}/${bindir}/xar
384 rm -rf ${D}/${includedir}/xar
385 rm -f ${D}/${libdir}/libxar*
386
387 rm -f ${D}/${bindir}/lz*
388 rm -f ${D}/${bindir}/unlzma
389 rm -f ${D}/${bindir}/unxz
390 rm -f ${D}/${bindir}/xz*
391 rm -rf ${D}/${includedir}/lzma*
392 rm -f ${D}/${mandir}/man1/lz*.1
393 rm -f ${D}/${libdir}/pkgconfig/liblzma*
394
395 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
396 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
397
398 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
399 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
400 #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
401
402 # We don't want the default macro set
403 rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
404
405 rm -f ${D}/${libdir}/rpm/dbconvert.sh
406
407 rm -f ${D}/${libdir}/rpm/libsqldb.*
408
409 # We don't want, nor need the Mandriva multiarch items
410 rm -f ${D}/${bindir}/multiarch-dispatch
411 rm -f ${D}/${bindir}/multiarch-platform
412 rm -f ${D}/${libdir}/rpm/check-multiarch-files
413 rm -f ${D}/${libdir}/rpm/mkmultiarch
414 rm -f ${D}/${includedir}/multiarch-dispatch.h
415
416 rm -f ${D}/${libdir}/rpm/gstreamer.sh
417 rm -f ${D}/${libdir}/rpm/gem_helper.rb
418 rm -f ${D}/${libdir}/rpm/rubygems.rb
419 rm -f ${D}/${libdir}/rpm/kmod-deps.sh
420 rm -f ${D}/${libdir}/rpm/pythoneggs.py
421 rm -f ${D}/${libdir}/rpm/macros.d/kernel
422 rm -f ${D}/${libdir}/rpm/macros.d/gstreamer
423 rm -f ${D}/${libdir}/rpm/bin/mgo
424 rm -f ${D}/${libdir}/rpm/bin/dbconvert
425 rm -f ${D}/${libdir}/rpm/bin/pom2spec
426
427}
428
429do_install_append_virtclass-native() {
430 create_wrapper ${D}/${bindir}/rpm \
431 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
432 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
433 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
434
435 create_wrapper ${D}/${bindir}/rpm2cpio \
436 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
437 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
438 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
439
440 create_wrapper ${D}/${bindir}/rpmbuild \
441 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
442 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
443 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
444
445 create_wrapper ${D}/${bindir}/rpmconstant \
446 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
447 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
448 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
449
450 for rpm_binary in ${D}/${libdir}/rpm/bin/rpm*; do
451 create_wrapper $rpm_binary
452 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
453 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
454 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
455 done
456
457 # Adjust popt macros to match...
458 cat ${D}/${libdir}/rpm/rpmpopt | sed -e "s,^\(rpm[^ ]*\)\([ ]\),\1.real\2," > ${D}/${libdir}/rpm/rpmpopt.new
459 mv ${D}/${libdir}/rpm/rpmpopt.new ${D}/${libdir}/rpm/rpmpopt
460}
461
462BBCLASSEXTEND = "native"