summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_4.16.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_4.16.1.2.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.16.1.2.bb164
1 files changed, 0 insertions, 164 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.16.1.2.bb b/meta/recipes-devtools/rpm/rpm_4.16.1.2.bb
deleted file mode 100644
index 9195d66dd1..0000000000
--- a/meta/recipes-devtools/rpm/rpm_4.16.1.2.bb
+++ /dev/null
@@ -1,164 +0,0 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c4eec0c20c6034b9407a09945b48a43f"
26
27SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.16.x \
28 file://environment.d-rpm.sh \
29 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
30 file://0001-Do-not-read-config-files-from-HOME.patch \
31 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
32 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
33 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
34 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
35 file://0001-Fix-build-with-musl-C-library.patch \
36 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
37 file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
38 file://0001-perl-disable-auto-reqs.patch \
39 file://0001-rpm-rpmio.c-restrict-virtual-memory-usage-if-limit-s.patch \
40 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
41 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
42 file://0001-tools-Add-error.h-for-non-glibc-case.patch \
43 "
44
45PE = "1"
46SRCREV = "278883a704ea36c97974d0f2d65d41abe78b0e2a"
47
48S = "${WORKDIR}/git"
49
50DEPENDS = "libgcrypt db file popt xz bzip2 elfutils python3"
51DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
52
53inherit autotools gettext pkgconfig python3native
54export PYTHON_ABI
55
56AUTOTOOLS_AUXDIR = "${S}/build-aux"
57
58# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
59EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
60
61EXTRA_OECONF_append = " --without-lua --enable-python --with-crypto=libgcrypt"
62EXTRA_OECONF_append_libc-musl = " --disable-nls --disable-openmp"
63
64# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
65# --localstatedir prevents rpm from writing its database to native sysroot when building images
66# Forcibly disable plugins for native/nativesdk, as the inhibit and prioreset
67# plugins both behave badly inside builds.
68EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
69EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --disable-plugins"
70
71BBCLASSEXTEND = "native nativesdk"
72
73PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)}"
74# The inhibit plugin serves no purpose outside of the target
75PACKAGECONFIG_remove_class-native = "inhibit"
76PACKAGECONFIG_remove_class-nativesdk = "inhibit"
77
78PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
79PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
80PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"
81
82ASNEEDED = ""
83
84# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
85# libmagic also has sysroot path contamination, so override it
86
87WRAPPER_TOOLS = " \
88 ${bindir}/rpm \
89 ${bindir}/rpm2archive \
90 ${bindir}/rpm2cpio \
91 ${bindir}/rpmbuild \
92 ${bindir}/rpmdb \
93 ${bindir}/rpmgraph \
94 ${bindir}/rpmkeys \
95 ${bindir}/rpmsign \
96 ${bindir}/rpmspec \
97 ${libdir}/rpm/rpmdeps \
98"
99
100do_configure_prepend() {
101 mkdir -p ${S}/build-aux
102}
103
104do_install_append_class-native() {
105 for tool in ${WRAPPER_TOOLS}; do
106 test -x ${D}$tool && create_wrapper ${D}$tool \
107 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
108 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
109 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
110 RPM_NO_CHROOT_FOR_SCRIPTS=1
111 done
112}
113
114do_install_append_class-nativesdk() {
115 for tool in ${WRAPPER_TOOLS}; do
116 test -x ${D}$tool && create_wrapper ${D}$tool \
117 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
118 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
119 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
120 RPM_NO_CHROOT_FOR_SCRIPTS=1
121 done
122
123 rm -rf ${D}/var
124
125 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
126 install -m 644 ${WORKDIR}/environment.d-rpm.sh ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
127}
128
129# Rpm's make install creates var/tmp which clashes with base-files packaging
130do_install_append_class-target() {
131 rm -rf ${D}/var
132}
133
134do_install_append () {
135 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
136 ${D}/${libdir}/rpm/macros
137
138 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
139 ${D}${libdir}/rpm/pythondistdeps.py
140}
141
142FILES_${PN} += "${libdir}/rpm-plugins/*.so \
143 "
144FILES_${PN}_append_class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/rpm.sh"
145
146FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \
147 "
148
149PACKAGES += "python3-rpm"
150PROVIDES += "python3-rpm"
151FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
152
153# rpm 5.x was packaging the rpm build tools separately
154RPROVIDES_${PN} += "rpm-build"
155
156RDEPENDS_${PN} = "bash perl python3-core"
157
158PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
159
160# Do not specify a sysroot when compiling on a target.
161rpm_package_preprocess () {
162 sed -i -e 's:--sysroot[^ ]*::g' \
163 ${PKGD}/${libdir}/rpm/macros
164}