diff options
Diffstat (limited to 'meta/recipes-devtools/repo/repo_2.18.bb')
-rw-r--r-- | meta/recipes-devtools/repo/repo_2.18.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/repo/repo_2.18.bb b/meta/recipes-devtools/repo/repo_2.18.bb new file mode 100644 index 0000000000..bf5e8d0429 --- /dev/null +++ b/meta/recipes-devtools/repo/repo_2.18.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | # SPDX-License-Identifier: MIT | ||
2 | # Copyright (C) 2021 iris-GmbH infrared & intelligent sensors | ||
3 | |||
4 | SUMMARY = "Tool for managing many Git repositories" | ||
5 | DESCRIPTION = "Repo is a tool built on top of Git. Repo helps manage many Git repositories, does the uploads to revision control systems, and automates parts of the development workflow." | ||
6 | HOMEPAGE = "https://android.googlesource.com/tools/repo" | ||
7 | SECTION = "console/utils" | ||
8 | |||
9 | LICENSE = "Apache-2.0" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
11 | |||
12 | SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main" | ||
13 | SRCREV = "4a478edb443864561089b2699c9e65c85fc5e036" | ||
14 | |||
15 | SRC_URI += "file://0001-python3-shebang.patch" | ||
16 | |||
17 | MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | do_set_fixed_rev() { | ||
22 | sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo | ||
23 | } | ||
24 | |||
25 | do_patch[postfuncs] += "do_set_fixed_rev" | ||
26 | |||
27 | do_install() { | ||
28 | install -D ${WORKDIR}/git/repo ${D}${bindir}/repo | ||
29 | } | ||
30 | |||
31 | RDEPENDS:${PN} = "python3 git" | ||
32 | |||
33 | BBCLASSEXTEND = "native nativesdk" | ||