summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/repo/repo_2.17.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/repo/repo_2.17.3.bb')
-rw-r--r--meta/recipes-devtools/repo/repo_2.17.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/repo/repo_2.17.3.bb b/meta/recipes-devtools/repo/repo_2.17.3.bb
new file mode 100644
index 0000000000..f7bbb22964
--- /dev/null
+++ b/meta/recipes-devtools/repo/repo_2.17.3.bb
@@ -0,0 +1,28 @@
1# SPDX-License-Identifier: MIT
2# Copyright (C) 2021 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "Tool for managing many Git repositories"
5DESCRIPTION = "Repo is a tool built on top of Git. Repo helps manage many Git repositories, does the uploads to revision control systems, and automates parts of the development workflow."
6HOMEPAGE = "https://android.googlesource.com/tools/repo"
7SECTION = "console/utils"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main"
13SRCREV = "11b30b91df1f0e03b53da970ec2588e85817bacc"
14
15SRC_URI += "file://0001-python3-shebang.patch \
16 file://0001-Set-REPO_REV-to-v2.17.3.patch"
17
18MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git"
19
20S = "${WORKDIR}/git"
21
22do_install() {
23 install -D ${WORKDIR}/git/repo ${D}${bindir}/repo
24}
25
26RDEPENDS:${PN} = "python3 git"
27
28BBCLASSEXTEND = "native nativesdk"