summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_3.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_3.1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_3.1.0.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_3.1.0.bb b/meta/recipes-devtools/qemu/qemu_3.1.0.bb
new file mode 100644
index 0000000000..67cebcc830
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_3.1.0.bb
@@ -0,0 +1,56 @@
1require qemu.inc
2
3inherit ptest
4
5RDEPENDS_${PN}-ptest = "bash make"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
8 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
9
10SRC_URI = "https://download.qemu.org/${BPN}-${PV}.tar.xz \
11 file://powerpc_rom.bin \
12 file://0001-sdl.c-allow-user-to-disable-pointer-grabs.patch \
13 file://0002-qemu-Add-missing-wacom-HID-descriptor.patch \
14 file://0003-Add-subpackage-ptest-which-runs-all-unit-test-cases-.patch \
15 file://run-ptest \
16 file://0004-qemu-Add-addition-environment-space-to-boot-loader-q.patch \
17 file://0005-qemu-disable-Valgrind.patch \
18 file://0006-qemu-Limit-paths-searched-during-user-mode-emulation.patch \
19 file://0007-qemu-native-set-ld.bfd-fix-cflags-and-set-some-envir.patch \
20 file://0008-chardev-connect-socket-to-a-spawned-command.patch \
21 file://0009-apic-fixup-fallthrough-to-PIC.patch \
22 file://0010-linux-user-Fix-webkitgtk-hangs-on-32-bit-x86-target.patch \
23 file://0011-Revert-linux-user-fix-mmap-munmap-mprotect-mremap-sh.patch \
24 "
25UPSTREAM_CHECK_REGEX = "qemu-(?P<pver>\d+(\.\d+)+)\.tar"
26
27SRC_URI_append_class-native = " \
28 file://0012-fix-libcap-header-issue-on-some-distro.patch \
29 file://0013-cpus.c-Add-error-messages-when-qemi_cpu_kick_thread-.patch \
30 "
31
32SRC_URI[md5sum] = "fb687ce0b02d3bf4327e36d3b99427a8"
33SRC_URI[sha256sum] = "6a0508df079a0a33c2487ca936a56c12122f105b8a96a44374704bef6c69abfc"
34
35COMPATIBLE_HOST_mipsarchn32 = "null"
36COMPATIBLE_HOST_mipsarchn64 = "null"
37
38do_install_append() {
39 # Prevent QA warnings about installed ${localstatedir}/run
40 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
41 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
42}
43
44do_compile_ptest() {
45 make buildtest-TESTS
46}
47
48do_install_ptest() {
49 cp -rL ${B}/tests ${D}${PTEST_PATH}
50 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
51
52 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
53 # Don't check the file genreated by configure
54 sed -i -e '/wildcard config-host.mak/d' \
55 -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
56}