summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_2.8.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_2.8.1.1.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_2.8.1.1.bb60
1 files changed, 0 insertions, 60 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_2.8.1.1.bb b/meta/recipes-devtools/qemu/qemu_2.8.1.1.bb
deleted file mode 100644
index a4ddb7f989..0000000000
--- a/meta/recipes-devtools/qemu/qemu_2.8.1.1.bb
+++ /dev/null
@@ -1,60 +0,0 @@
1require qemu.inc
2
3inherit ptest
4
5RDEPENDS_${PN}-ptest = "bash make"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
8 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
9
10SRC_URI = "http://wiki.qemu-project.org/download/${BP}.tar.bz2 \
11 file://powerpc_rom.bin \
12 file://disable-grabs.patch \
13 file://exclude-some-arm-EABI-obsolete-syscalls.patch \
14 file://wacom.patch \
15 file://add-ptest-in-makefile.patch \
16 file://run-ptest \
17 file://configure-fix-Darwin-target-detection.patch \
18 file://qemu-enlarge-env-entry-size.patch \
19 file://no-valgrind.patch \
20 file://pathlimit.patch \
21 file://qemu-2.5.0-cflags.patch \
22 file://glibc-2.25.patch \
23 file://0001-Provide-support-for-the-CUSE-TPM.patch \
24 file://0002-Introduce-condition-to-notify-waiters-of-completed-c.patch \
25 file://0003-Introduce-condition-in-TPM-backend-for-notification.patch \
26 file://0004-Add-support-for-VM-suspend-resume-for-TPM-TIS.patch \
27 file://CVE-2016-9908.patch \
28 file://CVE-2016-9912.patch \
29 file://0001-replace-struct-ucontext-with-ucontext_t-type.patch \
30 file://apic-fixup-fallthrough-to-PIC.patch \
31 "
32
33SRC_URI_append_class-native = " \
34 file://fix-libcap-header-issue-on-some-distro.patch \
35 file://cpus.c-qemu_cpu_kick_thread_debugging.patch \
36 "
37
38SRC_URI[md5sum] = "a6a23a0c59fd0f8ec564b0fb89a79954"
39SRC_URI[sha256sum] = "f62ab18a1fb9ff5b4c81ed44becc945b11581eff777618141bdb787da55d3638"
40
41COMPATIBLE_HOST_mipsarchn32 = "null"
42COMPATIBLE_HOST_mipsarchn64 = "null"
43
44do_install_append() {
45 # Prevent QA warnings about installed ${localstatedir}/run
46 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
47 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
48}
49
50do_compile_ptest() {
51 make buildtest-TESTS
52}
53
54do_install_ptest() {
55 cp -rL ${B}/tests ${D}${PTEST_PATH}
56 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
57
58 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
59}
60