summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_2.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_2.11.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_2.11.0.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_2.11.0.bb b/meta/recipes-devtools/qemu/qemu_2.11.0.bb
new file mode 100644
index 0000000000..ccd8917f8d
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_2.11.0.bb
@@ -0,0 +1,58 @@
1require qemu.inc
2
3inherit ptest
4
5RDEPENDS_${PN}-ptest = "bash make"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
8 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
9
10SRC_URI = "http://wiki.qemu-project.org/download/${BP}.tar.bz2 \
11 file://powerpc_rom.bin \
12 file://disable-grabs.patch \
13 file://wacom.patch \
14 file://add-ptest-in-makefile-v10.patch \
15 file://run-ptest \
16 file://qemu-enlarge-env-entry-size.patch \
17 file://no-valgrind.patch \
18 file://pathlimit.patch \
19 file://qemu-2.5.0-cflags.patch \
20 file://glibc-2.25.patch \
21 file://chardev-connect-socket-to-a-spawned-command.patch \
22 file://apic-fixup-fallthrough-to-PIC.patch \
23 file://linux-user-Fix-webkitgtk-hangs-on-32-bit-x86-target.patch \
24 "
25UPSTREAM_CHECK_REGEX = "qemu-(?P<pver>\d+\..*)\.tar"
26
27
28SRC_URI_append_class-native = " \
29 file://fix-libcap-header-issue-on-some-distro.patch \
30 file://cpus.c-qemu_cpu_kick_thread_debugging.patch \
31 "
32
33SRC_URI[md5sum] = "335994a755bc655e88a87aeb36bfc0b9"
34SRC_URI[sha256sum] = "c4f034c7665a84a1c3be72c8da37f3c31ec063475699df062ab646d8b2e17fcb"
35
36COMPATIBLE_HOST_mipsarchn32 = "null"
37COMPATIBLE_HOST_mipsarchn64 = "null"
38
39do_install_append() {
40 # Prevent QA warnings about installed ${localstatedir}/run
41 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
42 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
43}
44
45do_compile_ptest() {
46 make buildtest-TESTS
47}
48
49do_install_ptest() {
50 cp -rL ${B}/tests ${D}${PTEST_PATH}
51 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
52
53 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
54 # Don't check the file genreated by configure
55 sed -i -e '/wildcard config-host.mak/d' \
56 -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
57}
58