summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb b/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb
new file mode 100644
index 0000000000..5bf528bec1
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-system-native_3.1.1.1.bb
@@ -0,0 +1,23 @@
1BPN = "qemu"
2
3require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
8DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native"
9
10EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
11
12PACKAGECONFIG ??= "fdt alsa kvm"
13
14# Handle distros such as CentOS 5 32-bit that do not have kvm support
15PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
16
17do_install_append() {
18 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
19
20 # The following is also installed by qemu-native
21 rm -f ${D}${datadir}/qemu/trace-events-all
22 rm -rf ${D}${datadir}/qemu/keymaps
23}