summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 9ded75b373..90b397f3ce 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -61,7 +61,7 @@ do_configure_prepend() {
61 61
62do_compile() { 62do_compile() {
63 # regenerate platform specific files, because they depend on system headers 63 # regenerate platform specific files, because they depend on system headers
64 cd Lib/plat-linux2 64 cd ${S}/Lib/plat-linux2
65 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \ 65 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \
66 ${S}/Tools/scripts/h2py.py -i '(u_long)' \ 66 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
67 ${STAGING_INCDIR}/dlfcn.h \ 67 ${STAGING_INCDIR}/dlfcn.h \
@@ -93,7 +93,7 @@ do_compile() {
93 install -m 0644 Makefile Makefile.sysroot 93 install -m 0644 Makefile Makefile.sysroot
94 94
95 export CROSS_COMPILE="${TARGET_PREFIX}" 95 export CROSS_COMPILE="${TARGET_PREFIX}"
96 export PYTHONBUILDDIR="${S}" 96 export PYTHONBUILDDIR="${B}"
97 97
98 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \ 98 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
99 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \ 99 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
@@ -110,7 +110,7 @@ do_install() {
110 install -m 0644 Makefile.orig Makefile 110 install -m 0644 Makefile.orig Makefile
111 111
112 export CROSS_COMPILE="${TARGET_PREFIX}" 112 export CROSS_COMPILE="${TARGET_PREFIX}"
113 export PYTHONBUILDDIR="${S}" 113 export PYTHONBUILDDIR="${B}"
114 114
115 # After swizzling the makefile, we need to run the build again. 115 # After swizzling the makefile, we need to run the build again.
116 # install can race with the build so we have to run this first, then install 116 # install can race with the build so we have to run this first, then install