summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.15.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.15.bb25
1 files changed, 2 insertions, 23 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.15.bb b/meta/recipes-devtools/python/python_2.7.15.bb
index 3044c3d363..1168f2a167 100644
--- a/meta/recipes-devtools/python/python_2.7.15.bb
+++ b/meta/recipes-devtools/python/python_2.7.15.bb
@@ -23,7 +23,6 @@ SRC_URI += "\
23 file://avoid_warning_about_tkinter.patch \ 23 file://avoid_warning_about_tkinter.patch \
24 file://avoid_warning_for_sunos_specific_module.patch \ 24 file://avoid_warning_for_sunos_specific_module.patch \
25 file://python-2.7.3-remove-bsdb-rpath.patch \ 25 file://python-2.7.3-remove-bsdb-rpath.patch \
26 file://fix-makefile-for-ptest.patch \
27 file://run-ptest \ 26 file://run-ptest \
28 file://parallel-makeinst-create-bindir.patch \ 27 file://parallel-makeinst-create-bindir.patch \
29 file://use_sysroot_ncurses_instead_of_host.patch \ 28 file://use_sysroot_ncurses_instead_of_host.patch \
@@ -34,7 +33,7 @@ SRC_URI += "\
34 33
35S = "${WORKDIR}/Python-${PV}" 34S = "${WORKDIR}/Python-${PV}"
36 35
37inherit autotools multilib_header python-dir pythonnative 36inherit autotools multilib_header python-dir pythonnative ptest
38 37
39CONFIGUREOPTS += " --with-system-ffi " 38CONFIGUREOPTS += " --with-system-ffi "
40 39
@@ -167,27 +166,7 @@ FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
167RDEPENDS_${PN}-modules += "${PN}-misc" 166RDEPENDS_${PN}-modules += "${PN}-misc"
168 167
169# ptest 168# ptest
170RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests" 169RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip"
171#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten
172inherit ptest
173
174# This must come after inherit ptest for the override to take effect
175do_install_ptest() {
176 cp ${B}/Makefile ${D}${PTEST_PATH}
177 sed -e s:LIBDIR/python/ptest:${PTEST_PATH}:g \
178 -e s:LIBDIR:${libdir}:g \
179 -i ${D}${PTEST_PATH}/run-ptest
180
181 #Remove build host references
182 sed -i \
183 -e 's:--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
184 -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \
185 -e 's|${DEBUG_PREFIX_MAP}||g' \
186 -e 's:${HOSTTOOLS_DIR}/::g' \
187 -e 's:${RECIPE_SYSROOT}::g' \
188 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
189 ${D}/${PTEST_PATH}/Makefile
190}
191 170
192# catch manpage 171# catch manpage
193PACKAGES += "${PN}-man" 172PACKAGES += "${PN}-man"