summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.12.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.12.bb170
1 files changed, 170 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.12.bb b/meta/recipes-devtools/python/python_2.7.12.bb
new file mode 100644
index 0000000000..22b91d4d30
--- /dev/null
+++ b/meta/recipes-devtools/python/python_2.7.12.bb
@@ -0,0 +1,170 @@
1require python.inc
2DEPENDS = "python-native libffi bzip2 db gdbm openssl readline sqlite3 zlib"
3PR = "${INC_PR}"
4
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI += "\
8 file://01-use-proper-tools-for-cross-build.patch \
9 file://03-fix-tkinter-detection.patch \
10 file://06-avoid_usr_lib_termcap_path_in_linking.patch \
11 ${DISTRO_SRC_URI} \
12 file://multilib.patch \
13 file://cgi_py.patch \
14 file://setup_py_skip_cross_import_check.patch \
15 file://add-md5module-support.patch \
16 file://host_include_contamination.patch \
17 file://fix_for_using_different_libdir.patch \
18 file://setuptweaks.patch \
19 file://check-if-target-is-64b-not-host.patch \
20 file://search_db_h_in_inc_dirs_and_avoid_warning.patch \
21 file://avoid_warning_about_tkinter.patch \
22 file://avoid_warning_for_sunos_specific_module.patch \
23 file://python-2.7.3-remove-bsdb-rpath.patch \
24 file://fix-makefile-for-ptest.patch \
25 file://run-ptest \
26 file://parallel-makeinst-create-bindir.patch \
27 file://use_sysroot_ncurses_instead_of_host.patch \
28 file://add-CROSSPYTHONPATH-for-PYTHON_FOR_BUILD.patch \
29 file://CVE-2016-1000110.patch \
30"
31
32S = "${WORKDIR}/Python-${PV}"
33
34inherit autotools multilib_header python-dir pythonnative
35
36CONFIGUREOPTS += " --with-system-ffi "
37
38EXTRA_OECONF += "ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"
39
40do_configure_append() {
41 rm -f ${S}/Makefile.orig
42 autoreconf -Wcross --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
43}
44
45do_compile() {
46 # regenerate platform specific files, because they depend on system headers
47 cd ${S}/Lib/plat-linux2
48 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \
49 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
50 ${STAGING_INCDIR}/dlfcn.h \
51 ${STAGING_INCDIR}/linux/cdrom.h \
52 ${STAGING_INCDIR}/netinet/in.h \
53 ${STAGING_INCDIR}/sys/types.h
54 sed -e 's,${STAGING_DIR_HOST},,g' -i *.py
55 cd -
56
57 # remove any bogus LD_LIBRARY_PATH
58 sed -i -e s,RUNSHARED=.*,RUNSHARED=, Makefile
59
60 if [ ! -f Makefile.orig ]; then
61 install -m 0644 Makefile Makefile.orig
62 fi
63 sed -i -e 's#^LDFLAGS=.*#LDFLAGS=${LDFLAGS} -L. -L${STAGING_LIBDIR}#g' \
64 -e 's,libdir=${libdir},libdir=${STAGING_LIBDIR},g' \
65 -e 's,libexecdir=${libexecdir},libexecdir=${STAGING_DIR_HOST}${libexecdir},g' \
66 -e 's,^LIBDIR=.*,LIBDIR=${STAGING_LIBDIR},g' \
67 -e 's,includedir=${includedir},includedir=${STAGING_INCDIR},g' \
68 -e 's,^INCLUDEDIR=.*,INCLUDE=${STAGING_INCDIR},g' \
69 -e 's,^CONFINCLUDEDIR=.*,CONFINCLUDE=${STAGING_INCDIR},g' \
70 Makefile
71 # save copy of it now, because if we do it in do_install and
72 # then call do_install twice we get Makefile.orig == Makefile.sysroot
73 install -m 0644 Makefile Makefile.sysroot
74
75 export CROSS_COMPILE="${TARGET_PREFIX}"
76 export PYTHONBUILDDIR="${B}"
77
78 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
79 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
80 STAGING_LIBDIR=${STAGING_LIBDIR} \
81 STAGING_INCDIR=${STAGING_INCDIR} \
82 STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \
83 OPT="${CFLAGS}"
84}
85
86do_install() {
87 # make install needs the original Makefile, or otherwise the inclues would
88 # go to ${D}${STAGING...}/...
89 install -m 0644 Makefile.orig Makefile
90
91 export CROSS_COMPILE="${TARGET_PREFIX}"
92 export PYTHONBUILDDIR="${B}"
93
94 # After swizzling the makefile, we need to run the build again.
95 # install can race with the build so we have to run this first, then install
96 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
97 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
98 CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ \
99 STAGING_LIBDIR=${STAGING_LIBDIR} \
100 STAGING_INCDIR=${STAGING_INCDIR} \
101 STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \
102 DESTDIR=${D} LIBDIR=${libdir}
103
104 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
105 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
106 CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ \
107 STAGING_LIBDIR=${STAGING_LIBDIR} \
108 STAGING_INCDIR=${STAGING_INCDIR} \
109 STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \
110 DESTDIR=${D} LIBDIR=${libdir} install
111
112 install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
113
114 if [ -e ${WORKDIR}/sitecustomize.py ]; then
115 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
116 fi
117
118 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
119}
120
121do_install_append_class-nativesdk () {
122 create_wrapper ${D}${bindir}/python2.7 PYTHONHOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
123}
124
125SSTATE_SCAN_FILES += "Makefile"
126PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
127
128py_package_preprocess () {
129 # copy back the old Makefile to fix target package
130 install -m 0644 ${B}/Makefile.orig ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
131
132 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
133 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
134 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile \
135 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py
136}
137
138require python-${PYTHON_MAJMIN}-manifest.inc
139
140# manual dependency additions
141RPROVIDES_${PN}-core = "${PN}"
142RRECOMMENDS_${PN}-core = "${PN}-readline"
143RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python-modules"
144RRECOMMENDS_${PN}-crypt = "openssl"
145
146# package libpython2
147PACKAGES =+ "lib${BPN}2"
148FILES_lib${BPN}2 = "${libdir}/libpython*.so.*"
149
150# catch all the rest (unsorted)
151PACKAGES += "${PN}-misc"
152FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
153RDEPENDS_${PN}-modules += "${PN}-misc"
154RDEPENDS_${PN}-ptest = "${PN}-modules"
155#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten
156inherit ptest
157
158# This must come after inherit ptest for the override to take effect
159do_install_ptest() {
160 cp ${B}/Makefile ${D}${PTEST_PATH}
161 sed -e s:LIBDIR/python/ptest:${PTEST_PATH}:g \
162 -e s:LIBDIR:${libdir}:g \
163 -i ${D}${PTEST_PATH}/run-ptest
164}
165
166# catch manpage
167PACKAGES += "${PN}-man"
168FILES_${PN}-man = "${datadir}/man"
169
170BBCLASSEXTEND = "nativesdk"