summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.6.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python_2.6.5.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.6.5.bb26
1 files changed, 14 insertions, 12 deletions
diff --git a/meta/recipes-devtools/python/python_2.6.5.bb b/meta/recipes-devtools/python/python_2.6.5.bb
index 674b673f94..5c54889e91 100644
--- a/meta/recipes-devtools/python/python_2.6.5.bb
+++ b/meta/recipes-devtools/python/python_2.6.5.bb
@@ -82,18 +82,18 @@ do_install() {
82require python-${PYTHON_MAJMIN}-manifest.inc 82require python-${PYTHON_MAJMIN}-manifest.inc
83 83
84# manual dependency additions 84# manual dependency additions
85RPROVIDES_python-core = "python" 85RPROVIDES_${PN}-core = "python"
86RRECOMMENDS_python-core = "python-readline" 86RRECOMMENDS_${PN}-core = "python-readline"
87RRECOMMENDS_python-crypt = "openssl" 87RRECOMMENDS_${PN}-crypt = "openssl"
88 88
89# add sitecustomize 89# add sitecustomize
90FILES_python-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py" 90FILES_${PN}-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py"
91# ship 2to3 91# ship 2to3
92FILES_python-core += "${bindir}/2to3" 92FILES_${PN}-core += "${bindir}/2to3"
93 93
94# package libpython2 94# package libpython2
95PACKAGES =+ "libpython2" 95PACKAGES =+ "lib${PN}2"
96FILES_libpython2 = "${libdir}/libpython*.so*" 96FILES_lib${PN}2 = "${libdir}/libpython*.so*"
97 97
98# additional stuff -dev 98# additional stuff -dev
99 99
@@ -111,12 +111,14 @@ FILES_${PN}-dev = "\
111" 111"
112 112
113# catch debug extensions (isn't that already in python-core-dbg?) 113# catch debug extensions (isn't that already in python-core-dbg?)
114FILES_python-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug" 114FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
115 115
116# catch all the rest (unsorted) 116# catch all the rest (unsorted)
117PACKAGES += "python-misc" 117PACKAGES += "${PN}-misc"
118FILES_python-misc = "${libdir}/python${PYTHON_MAJMIN}" 118FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
119 119
120# catch manpage 120# catch manpage
121PACKAGES += "python-man" 121PACKAGES += "${PN}-man"
122FILES_python-man = "${datadir}/man" 122FILES_${PN}-man = "${datadir}/man"
123
124BBCLASSEXTEND = "nativesdk"