summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.8.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.8.18.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.8.18.bb369
1 files changed, 369 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.8.18.bb b/meta/recipes-devtools/python/python3_3.8.18.bb
new file mode 100644
index 0000000000..9d0f72ecf9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3_3.8.18.bb
@@ -0,0 +1,369 @@
1SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3DESCRIPTION = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
4LICENSE = "PSF-2.0 & BSD-0-Clause"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=07fc4b9a9c0c0e48050ed38a5e72552b"
8
9SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
10 file://run-ptest \
11 file://create_manifest3.py \
12 file://get_module_deps3.py \
13 file://python3-manifest.json \
14 file://check_build_completeness.py \
15 file://cgi_py.patch \
16 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
17 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
18 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
19 file://python-config.patch \
20 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
21 file://0001-Do-not-hardcode-lib-as-location-for-site-packages-an.patch \
22 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
23 file://0001-Lib-sysconfig.py-fix-another-place-where-lib-is-hard.patch \
24 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
25 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
26 file://crosspythonpath.patch \
27 file://reformat_sysconfig.py \
28 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
29 file://0001-test_locale.py-correct-the-test-output-format.patch \
30 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
31 file://0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
32 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
33 file://0001-configure.ac-fix-LIBPL.patch \
34 file://0001-python3-Do-not-hardcode-lib-for-distutils.patch \
35 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
36 file://makerace.patch \
37 file://CVE-2023-24329.patch \
38 "
39
40SRC_URI_append_class-native = " \
41 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
42 file://12-distutils-prefix-is-inside-staging-area.patch \
43 file://0001-Don-t-search-system-for-headers-libraries.patch \
44 "
45
46SRC_URI[md5sum] = "5ea6267ea00513fc31d3746feb35842d"
47SRC_URI[sha256sum] = "3ffb71cd349a326ba7b2fadc7e7df86ba577dd9c4917e52a8401adbda7405e3f"
48
49# exclude pre-releases for both python 2.x and 3.x
50UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
51
52CVE_PRODUCT = "python"
53
54# Upstream consider this expected behaviour
55CVE_CHECK_WHITELIST += "CVE-2007-4559"
56# This is not exploitable when glibc has CVE-2016-10739 fixed.
57CVE_CHECK_WHITELIST += "CVE-2019-18348"
58
59# This is windows only issue.
60CVE_CHECK_WHITELIST += "CVE-2020-15523 CVE-2022-26488"
61# The mailcap module is insecure by design, so this can't be fixed in a meaningful way.
62# The module will be removed in the future and flaws documented.
63CVE_CHECK_WHITELIST += "CVE-2015-20107"
64# Not an issue, in fact expected behaviour
65CVE_CHECK_WHITELIST += "CVE-2023-36632"
66
67PYTHON_MAJMIN = "3.8"
68
69S = "${WORKDIR}/Python-${PV}"
70
71BBCLASSEXTEND = "native nativesdk"
72
73inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
74
75MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
76
77ALTERNATIVE_${PN}-dev = "python3-config"
78ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
79ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
80
81
82DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2 autoconf-archive"
83DEPENDS_append_class-target = " python3-native"
84DEPENDS_append_class-nativesdk = " python3-native"
85
86EXTRA_OECONF = " --without-ensurepip --enable-shared"
87EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}"
88
89export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
90
91EXTRANATIVEPATH += "python3-native"
92
93CACHED_CONFIGUREVARS = " \
94 ac_cv_file__dev_ptmx=yes \
95 ac_cv_file__dev_ptc=no \
96 ac_cv_working_tzset=yes \
97"
98python() {
99 # PGO currently causes builds to not be reproducible, so disable it for
100 # now. See YOCTO #13407
101 if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
102 d.setVar('PACKAGECONFIG_PGO', 'pgo')
103 else:
104 d.setVar('PACKAGECONFIG_PGO', '')
105}
106
107PACKAGECONFIG_class-target ??= "readline ${PACKAGECONFIG_PGO} gdbm"
108PACKAGECONFIG_class-native ??= "readline gdbm"
109PACKAGECONFIG_class-nativesdk ??= "readline gdbm"
110PACKAGECONFIG[readline] = ",,readline"
111# Use profile guided optimisation by running PyBench inside qemu-user
112PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
113PACKAGECONFIG[tk] = ",,tk"
114PACKAGECONFIG[gdbm] = ",,gdbm"
115
116do_configure_prepend () {
117 mkdir -p ${B}/Modules
118 cat > ${B}/Modules/Setup.local << EOF
119*disabled*
120${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
121${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
122EOF
123}
124
125CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
126
127EXTRA_OEMAKE = '\
128 STAGING_LIBDIR=${STAGING_LIBDIR} \
129 STAGING_INCDIR=${STAGING_INCDIR} \
130 LIB=${baselib} \
131'
132
133do_compile_prepend_class-target() {
134 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
135 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
136 cat >pgo-wrapper <<EOF
137#!/bin/sh
138cd ${B}
139$qemu_binary "\$@"
140EOF
141 chmod +x pgo-wrapper
142 fi
143}
144
145do_install_prepend() {
146 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
147}
148
149do_install_append_class-target() {
150 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
151}
152
153do_install_append_class-native() {
154 # Make sure we use /usr/bin/env python
155 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
156 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
157 done
158 # Add a symlink to the native Python so that scripts can just invoke
159 # "nativepython" and get the right one without needing absolute paths
160 # (these often end up too long for the #! parser in the kernel as the
161 # buffer is 128 bytes long).
162 ln -s python3-native/python3 ${D}${bindir}/nativepython3
163}
164
165do_install_append() {
166 mkdir -p ${D}${libdir}/python-sysconfigdata
167 sysconfigfile=`find ${D} -name _sysconfig*.py`
168 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
169
170 sed -i \
171 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
172 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
173 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
174 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
175 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
176 ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
177}
178
179do_install_append_class-nativesdk () {
180 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
181}
182
183SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
184PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
185
186py_package_preprocess () {
187 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
188 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
189 -e 's|${DEBUG_PREFIX_MAP}||g' \
190 -e 's:${HOSTTOOLS_DIR}/::g' \
191 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
192 -e 's:${RECIPE_SYSROOT}::g' \
193 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
194 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
195 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
196 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
197
198 # Reformat _sysconfigdata after modifying it so that it remains
199 # reproducible
200 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
201 python3 ${WORKDIR}/reformat_sysconfig.py $c
202 done
203
204 # Recompile _sysconfigdata after modifying it
205 cd ${PKGD}
206 sysconfigfile=`find . -name _sysconfigdata_*.py`
207 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
208 -c "from py_compile import compile; compile('$sysconfigfile')"
209 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
210 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
211 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
212 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
213 cd -
214
215 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
216
217 #Remove the unneeded copy of target sysconfig data
218 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
219}
220
221# We want bytecode precompiled .py files (.pyc's) by default
222# but the user may set it on their own conf
223INCLUDE_PYCS ?= "1"
224
225python(){
226 import collections, json
227
228 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
229 # This python changes the datastore based on the contents of a file, so mark
230 # that dependency.
231 bb.parse.mark_dependency(d, filename)
232
233 with open(filename) as manifest_file:
234 manifest_str = manifest_file.read()
235 json_start = manifest_str.find('# EOC') + 6
236 manifest_file.seek(json_start)
237 manifest_str = manifest_file.read()
238 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
239
240 # First set RPROVIDES for -native case
241 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
242 pn = 'python3'
243 rprovides = d.getVar('RPROVIDES').split()
244
245 # ${PN}-misc-native is not in the manifest
246 rprovides.append(pn + '-misc-native')
247
248 for key in python_manifest:
249 pypackage = pn + '-' + key + '-native'
250 if pypackage not in rprovides:
251 rprovides.append(pypackage)
252
253 d.setVar('RPROVIDES_class-native', ' '.join(rprovides))
254
255 # Then work on the target
256 include_pycs = d.getVar('INCLUDE_PYCS')
257
258 packages = d.getVar('PACKAGES').split()
259 pn = d.getVar('PN')
260
261 newpackages=[]
262 for key in python_manifest:
263 pypackage = pn + '-' + key
264
265 if pypackage not in packages:
266 # We need to prepend, otherwise python-misc gets everything
267 # so we use a new variable
268 newpackages.append(pypackage)
269
270 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
271 d.setVar('FILES_' + pypackage, '')
272 for value in python_manifest[key]['files']:
273 d.appendVar('FILES_' + pypackage, ' ' + value)
274
275 # Add cached files
276 if include_pycs == '1':
277 for value in python_manifest[key]['cached']:
278 d.appendVar('FILES_' + pypackage, ' ' + value)
279
280 for value in python_manifest[key]['rdepends']:
281 # Make it work with or without $PN
282 if '${PN}' in value:
283 value=value.split('-', 1)[1]
284 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
285
286 for value in python_manifest[key].get('rrecommends', ()):
287 if '${PN}' in value:
288 value=value.split('-', 1)[1]
289 d.appendVar('RRECOMMENDS_' + pypackage, ' ' + pn + '-' + value)
290
291 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
292
293 # Prepending so to avoid python-misc getting everything
294 packages = newpackages + packages
295 d.setVar('PACKAGES', ' '.join(packages))
296 d.setVar('ALLOW_EMPTY_${PN}-modules', '1')
297 d.setVar('ALLOW_EMPTY_${PN}-pkgutil', '1')
298}
299
300# Files needed to create a new manifest
301
302do_create_manifest() {
303 # This task should be run with every new release of Python.
304 # We must ensure that PACKAGECONFIG enables everything when creating
305 # a new manifest, this is to base our new manifest on a complete
306 # native python build, containing all dependencies, otherwise the task
307 # wont be able to find the required files.
308 # e.g. BerkeleyDB is an optional build dependency so it may or may not
309 # be present, we must ensure it is.
310
311 cd ${WORKDIR}
312 # This needs to be executed by python-native and NOT by HOST's python
313 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
314 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
315}
316
317# bitbake python -c create_manifest
318# Make sure we have native python ready when we create a new manifest
319addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
320
321# manual dependency additions
322RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
323RRECOMMENDS_${PN}-crypt_append_class-target = " openssl ca-certificates"
324RRECOMMENDS_${PN}-crypt_append_class-nativesdk = " openssl ca-certificates"
325
326# For historical reasons PN is empty and provided by python3-modules
327FILES_${PN} = ""
328RPROVIDES_${PN}-modules = "${PN}"
329
330FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
331FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
332
333# provide python-pyvenv from python3-venv
334RPROVIDES_${PN}-venv += "python3-pyvenv"
335
336# package libpython3
337PACKAGES =+ "libpython3 libpython3-staticdev"
338FILES_libpython3 = "${libdir}/libpython*.so.*"
339FILES_libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
340INSANE_SKIP_${PN}-dev += "dev-elf"
341INSANE_SKIP_${PN}-ptest += "dev-deps"
342
343# catch all the rest (unsorted)
344PACKAGES += "${PN}-misc"
345RDEPENDS_${PN}-misc += "python3-core python3-email python3-codecs python3-pydoc python3-pickle python3-audio"
346RDEPENDS_${PN}-modules_append_class-target = " python3-misc"
347RDEPENDS_${PN}-modules_append_class-nativesdk = " python3-misc"
348FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
349
350# catch manpage
351PACKAGES += "${PN}-man"
352FILES_${PN}-man = "${datadir}/man"
353
354# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
355RDEPENDS_libpython3_append_libc-glibc = " libgcc"
356RDEPENDS_${PN}-ctypes_append_libc-glibc = " ${MLPREFIX}ldconfig"
357RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev unzip bzip2 libgcc tzdata-europe coreutils sed"
358RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9"
359RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
360RDEPENDS_${PN}-dev = ""
361
362RDEPENDS_${PN}-tests_append_class-target = " bash"
363RDEPENDS_${PN}-tests_append_class-nativesdk = " bash"
364
365# Python's tests contain large numbers of files we don't need in the recipe sysroots
366SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
367py3_sysroot_cleanup () {
368 rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
369}