summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.7.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.7.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.5.bb312
1 files changed, 312 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.5.bb b/meta/recipes-devtools/python/python3_3.7.5.bb
new file mode 100644
index 0000000000..c560c4a29d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3_3.7.5.bb
@@ -0,0 +1,312 @@
1SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3LICENSE = "PSFv2"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e466242989bd33c1bd2b6a526a742498"
7
8SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
9 file://run-ptest \
10 file://create_manifest3.py \
11 file://get_module_deps3.py \
12 file://python3-manifest.json \
13 file://check_build_completeness.py \
14 file://cgi_py.patch \
15 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
16 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
17 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
18 file://python-config.patch \
19 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
20 file://0001-Do-not-hardcode-lib-as-location-for-site-packages-an.patch \
21 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
22 file://0002-Don-t-do-runtime-test-to-get-float-byte-order.patch \
23 file://0003-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
24 file://0001-Lib-sysconfig.py-fix-another-place-where-lib-is-hard.patch \
25 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
26 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
27 file://crosspythonpath.patch \
28 file://reformat_sysconfig.py \
29 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
30 file://0001-test_locale.py-correct-the-test-output-format.patch \
31 "
32
33SRC_URI_append_class-native = " \
34 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
35 file://12-distutils-prefix-is-inside-staging-area.patch \
36 "
37SRC_URI_append_class-nativesdk = " \
38 file://0001-main.c-if-OEPYTHON3HOME-is-set-use-instead-of-PYTHON.patch \
39 "
40
41SRC_URI[md5sum] = "08ed8030b1183107c48f2092e79a87e2"
42SRC_URI[sha256sum] = "e85a76ea9f3d6c485ec1780fca4e500725a4a7bbc63c78ebc44170de9b619d94"
43
44# exclude pre-releases for both python 2.x and 3.x
45UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
46
47CVE_PRODUCT = "python"
48
49PYTHON_MAJMIN = "3.7"
50PYTHON_BINABI = "${PYTHON_MAJMIN}m"
51
52S = "${WORKDIR}/Python-${PV}"
53
54BBCLASSEXTEND = "native nativesdk"
55
56inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
57
58MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
59
60ALTERNATIVE_${PN}-dev = "python-config"
61ALTERNATIVE_LINK_NAME[python-config] = "${bindir}/python${PYTHON_BINABI}-config"
62ALTERNATIVE_TARGET[python-config] = "${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}"
63
64
65DEPENDS = "bzip2-replacement-native libffi bzip2 gdbm openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2"
66DEPENDS_append_class-target = " python3-native"
67DEPENDS_append_class-nativesdk = " python3-native"
68
69EXTRA_OECONF = " --without-ensurepip --enable-shared"
70EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}"
71
72export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
73
74EXTRANATIVEPATH += "python3-native"
75
76CACHED_CONFIGUREVARS = " \
77 ac_cv_file__dev_ptmx=yes \
78 ac_cv_file__dev_ptc=no \
79 ac_cv_working_tzset=yes \
80"
81
82PACKAGECONFIG_class-target ??= "readline ${@bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'pgo', '', d)}"
83PACKAGECONFIG_class-native ??= "readline"
84PACKAGECONFIG_class-nativesdk ??= "readline"
85PACKAGECONFIG[readline] = ",,readline"
86# Use profile guided optimisation by running PyBench inside qemu-user
87PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
88PACKAGECONFIG[tk] = ",,tk"
89
90CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
91
92EXTRA_OEMAKE = '\
93 STAGING_LIBDIR=${STAGING_LIBDIR} \
94 STAGING_INCDIR=${STAGING_INCDIR} \
95 LIB=${baselib} \
96'
97
98do_compile_prepend_class-target() {
99 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
100 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
101 cat >pgo-wrapper <<EOF
102#!/bin/sh
103cd ${B}
104$qemu_binary "\$@"
105EOF
106 chmod +x pgo-wrapper
107 fi
108}
109
110do_install_prepend() {
111 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
112}
113
114do_install_append_class-target() {
115 oe_multilib_header python${PYTHON_BINABI}/pyconfig.h
116}
117
118do_install_append_class-native() {
119 # Make sure we use /usr/bin/env python
120 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
121 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
122 done
123 # Add a symlink to the native Python so that scripts can just invoke
124 # "nativepython" and get the right one without needing absolute paths
125 # (these often end up too long for the #! parser in the kernel as the
126 # buffer is 128 bytes long).
127 ln -s python3-native/python3 ${D}${bindir}/nativepython3
128}
129
130do_install_append() {
131 mkdir -p ${D}${libdir}/python-sysconfigdata
132 sysconfigfile=`find ${D} -name _sysconfig*.py`
133 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
134
135 sed -i \
136 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
137 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
138 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
139 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
140 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
141 ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
142}
143
144do_install_append_class-nativesdk () {
145 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} OEPYTHON3HOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
146}
147
148SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
149PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
150
151py_package_preprocess () {
152 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
153 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
154 -e 's|${DEBUG_PREFIX_MAP}||g' \
155 -e 's:${HOSTTOOLS_DIR}/::g' \
156 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
157 -e 's:${RECIPE_SYSROOT}::g' \
158 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
159 ${PKGD}/${prefix}/lib/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
160 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
161 ${PKGD}/${bindir}/python${PYTHON_BINABI}-config
162
163 # Reformat _sysconfigdata after modifying it so that it remains
164 # reproducible
165 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
166 python3 ${WORKDIR}/reformat_sysconfig.py $c
167 done
168
169 # Recompile _sysconfigdata after modifying it
170 cd ${PKGD}
171 sysconfigfile=`find . -name _sysconfigdata_*.py`
172 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
173 -c "from py_compile import compile; compile('$sysconfigfile')"
174 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
175 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
176 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
177 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
178 cd -
179
180 mv ${PKGD}/${bindir}/python${PYTHON_BINABI}-config ${PKGD}/${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}
181
182 #Remove the unneeded copy of target sysconfig data
183 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
184}
185
186# We want bytecode precompiled .py files (.pyc's) by default
187# but the user may set it on their own conf
188INCLUDE_PYCS ?= "1"
189
190python(){
191 import collections, json
192
193 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
194 # This python changes the datastore based on the contents of a file, so mark
195 # that dependency.
196 bb.parse.mark_dependency(d, filename)
197
198 with open(filename) as manifest_file:
199 manifest_str = manifest_file.read()
200 json_start = manifest_str.find('# EOC') + 6
201 manifest_file.seek(json_start)
202 manifest_str = manifest_file.read()
203 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
204
205 # First set RPROVIDES for -native case
206 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
207 pn = 'python3'
208 rprovides = d.getVar('RPROVIDES').split()
209
210 for key in python_manifest:
211 pypackage = pn + '-' + key + '-native'
212 if pypackage not in rprovides:
213 rprovides.append(pypackage)
214
215 d.setVar('RPROVIDES_class-native', ' '.join(rprovides))
216
217 # Then work on the target
218 include_pycs = d.getVar('INCLUDE_PYCS')
219
220 packages = d.getVar('PACKAGES').split()
221 pn = d.getVar('PN')
222
223 newpackages=[]
224 for key in python_manifest:
225 pypackage= pn + '-' + key
226
227 if pypackage not in packages:
228 # We need to prepend, otherwise python-misc gets everything
229 # so we use a new variable
230 newpackages.append(pypackage)
231
232 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
233 d.setVar('FILES_' + pypackage, '')
234 for value in python_manifest[key]['files']:
235 d.appendVar('FILES_' + pypackage, ' ' + value)
236
237 # Add cached files
238 if include_pycs == '1':
239 for value in python_manifest[key]['cached']:
240 d.appendVar('FILES_' + pypackage, ' ' + value)
241
242 for value in python_manifest[key]['rdepends']:
243 # Make it work with or without $PN
244 if '${PN}' in value:
245 value=value.split('-')[1]
246 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
247 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
248
249 # Prepending so to avoid python-misc getting everything
250 packages = newpackages + packages
251 d.setVar('PACKAGES', ' '.join(packages))
252 d.setVar('ALLOW_EMPTY_${PN}-modules', '1')
253}
254
255# Files needed to create a new manifest
256
257do_create_manifest() {
258 # This task should be run with every new release of Python.
259 # We must ensure that PACKAGECONFIG enables everything when creating
260 # a new manifest, this is to base our new manifest on a complete
261 # native python build, containing all dependencies, otherwise the task
262 # wont be able to find the required files.
263 # e.g. BerkeleyDB is an optional build dependency so it may or may not
264 # be present, we must ensure it is.
265
266 cd ${WORKDIR}
267 # This needs to be executed by python-native and NOT by HOST's python
268 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
269 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
270}
271
272# bitbake python -c create_manifest
273addtask do_create_manifest
274
275# Make sure we have native python ready when we create a new manifest
276do_create_manifest[depends] += "${PN}:do_prepare_recipe_sysroot"
277do_create_manifest[depends] += "${PN}:do_patch"
278
279# manual dependency additions
280RPROVIDES_${PN}-modules = "${PN}"
281RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
282RRECOMMENDS_${PN}-crypt_append_class-target = " openssl ca-certificates"
283RRECOMMENDS_${PN}-crypt_append_class-nativesdk = " openssl ca-certificates"
284
285FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
286FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
287
288# provide python-pyvenv from python3-venv
289RPROVIDES_${PN}-venv += "python3-pyvenv"
290
291# package libpython3
292PACKAGES =+ "libpython3 libpython3-staticdev"
293FILES_libpython3 = "${libdir}/libpython*.so.*"
294FILES_libpython3-staticdev += "${prefix}/lib/python${PYTHON_MAJMIN}/config-${PYTHON_BINABI}-*/libpython${PYTHON_BINABI}.a"
295INSANE_SKIP_${PN}-dev += "dev-elf"
296
297# catch all the rest (unsorted)
298PACKAGES += "${PN}-misc"
299RDEPENDS_${PN}-misc += "python3-core python3-email python3-codecs"
300RDEPENDS_${PN}-modules_append_class-target = " python3-misc"
301RDEPENDS_${PN}-modules_append_class-nativesdk = " python3-misc"
302FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
303
304# catch manpage
305PACKAGES += "${PN}-man"
306FILES_${PN}-man = "${datadir}/man"
307
308RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2 libgcc tzdata-europe coreutils sed"
309RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9"
310RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
311RDEPENDS_${PN}-dev = ""
312