summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.7.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.4.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.4.bb b/meta/recipes-devtools/python/python3_3.7.4.bb
index c5a5db1dc3..e9ec6048de 100644
--- a/meta/recipes-devtools/python/python3_3.7.4.bb
+++ b/meta/recipes-devtools/python/python3_3.7.4.bb
@@ -25,6 +25,7 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
25 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \ 25 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
26 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \ 26 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
27 file://crosspythonpath.patch \ 27 file://crosspythonpath.patch \
28 file://reformat_sysconfig.py \
28 " 29 "
29 30
30SRC_URI_append_class-native = " \ 31SRC_URI_append_class-native = " \
@@ -157,6 +158,12 @@ py_package_preprocess () {
157 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \ 158 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
158 ${PKGD}/${bindir}/python${PYTHON_BINABI}-config 159 ${PKGD}/${bindir}/python${PYTHON_BINABI}-config
159 160
161 # Reformat _sysconfigdata after modifying it so that it remains
162 # reproducible
163 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
164 python3 ${WORKDIR}/reformat_sysconfig.py $c
165 done
166
160 # Recompile _sysconfigdata after modifying it 167 # Recompile _sysconfigdata after modifying it
161 cd ${PKGD} 168 cd ${PKGD}
162 sysconfigfile=`find . -name _sysconfigdata_*.py` 169 sysconfigfile=`find . -name _sysconfigdata_*.py`