summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-zipp_3.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-zipp_3.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-zipp_3.5.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-zipp_3.5.0.bb b/meta/recipes-devtools/python/python3-zipp_3.5.0.bb
new file mode 100644
index 0000000000..ab12601e4e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-zipp_3.5.0.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
2HOMEPAGE = "https://github.com/jaraco/zipp"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
5
6SRC_URI[sha256sum] = "f5812b1e007e48cff63449a5e9f4e7ebea716b4111f9c4f9a645f91d579bf0c4"
7
8DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
9
10inherit pypi setuptools3
11
12DEPENDS += "${PYTHON_PN}-toml-native"
13
14RDEPENDS_${PN} += "${PYTHON_PN}-compression \
15 ${PYTHON_PN}-math \
16 ${PYTHON_PN}-more-itertools"
17
18BBCLASSEXTEND = "native nativesdk"