summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-webcolors_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-webcolors_1.11.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-webcolors_1.11.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-webcolors_1.11.1.bb b/meta/recipes-devtools/python/python3-webcolors_1.11.1.bb
new file mode 100644
index 0000000000..2ec036ef35
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-webcolors_1.11.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=25b90379a52351261c51272e7923d240"
4
5SRC_URI[md5sum] = "54d28a7c80b3e4d974ec2fee86768be9"
6SRC_URI[sha256sum] = "76f360636957d1c976db7466bc71dcb713bb95ac8911944dffc55c01cb516de6"
7
8inherit pypi setuptools3 ptest
9
10RDEPENDS:${PN}:class-target = "\
11 ${PYTHON_PN}-stringold \
12"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}
26
27BBCLASSEXTEND = "native nativesdk"