summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-wcwidth_0.2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-wcwidth_0.2.12.bb')
-rw-r--r--meta/recipes-devtools/python/python3-wcwidth_0.2.12.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-wcwidth_0.2.12.bb b/meta/recipes-devtools/python/python3-wcwidth_0.2.12.bb
new file mode 100644
index 0000000000..ae845a39a7
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-wcwidth_0.2.12.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Library for building powerful interactive command lines in Python"
2DESCRIPTION = "Measures the displayed width of unicode strings in a terminal"
3HOMEPAGE = "https://github.com/jquast/wcwidth"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
6
7SRC_URI[sha256sum] = "f01c104efdf57971bcb756f054dd58ddec5204dd15fa31d6503ea57947d97c02"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-unittest-automake-output \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25BBCLASSEXTEND = "native nativesdk"