summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-urllib3_2.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-urllib3_2.0.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-urllib3_2.0.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-urllib3_2.0.4.bb b/meta/recipes-devtools/python/python3-urllib3_2.0.4.bb
new file mode 100644
index 0000000000..0abd2adf65
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-urllib3_2.0.4.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=52d273a3054ced561275d4d15260ecda"
5
6SRC_URI[sha256sum] = "8d22f86aae8ef5e410d4f539fde9ce6b2113a001bb4d189e0aed70642d602b11"
7
8inherit pypi python_hatchling
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-certifi \
12 ${PYTHON_PN}-cryptography \
13 ${PYTHON_PN}-email \
14 ${PYTHON_PN}-idna \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-pyopenssl \
18 ${PYTHON_PN}-threading \
19 ${PYTHON_PN}-logging \
20"
21
22CVE_PRODUCT = "urllib3"
23
24BBCLASSEXTEND = "native nativesdk"