summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-sphinx_5.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-sphinx_5.2.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx_5.2.3.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx_5.2.3.bb b/meta/recipes-devtools/python/python3-sphinx_5.2.3.bb
new file mode 100644
index 0000000000..957bd17fc0
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx_5.2.3.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=72c536e78c21c567311b193fe00cd253"
6
7PYPI_PACKAGE = "Sphinx"
8
9SRC_URI[sha256sum] = "5b10cb1022dac8c035f75767799c39217a05fc0fe2d6fe5597560d38e44f0363"
10
11inherit python_flit_core pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-alabaster \
21 python3-babel \
22 python3-docutils \
23 python3-imagesize \
24 python3-jinja2 \
25 python3-packaging \
26 python3-pygments \
27 python3-requests \
28 python3-snowballstemmer \
29 python3-sphinxcontrib-applehelp \
30 python3-sphinxcontrib-devhelp \
31 python3-sphinxcontrib-htmlhelp \
32 python3-sphinxcontrib-jsmath \
33 python3-sphinxcontrib-qthelp \
34 python3-sphinxcontrib-serializinghtml \
35 "
36
37BBCLASSEXTEND = "native nativesdk"