summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.2.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.2.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.2.1.bb b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.2.1.bb
new file mode 100644
index 0000000000..25de0159b6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.2.1.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Sphinx Theme reader"
2HOMEPAGE = "https://github.com/readthedocs/sphinx_rtd_theme"
3SECTION = "devel/python"
4LICENSE = "MIT & OFL-1.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a1db7d4ef426c2935227264e1d4ae8f9 \
6 file://OFL-License.txt;md5=4534c22e0147eadb6828bd9fe86d4868 \
7 file://Apache-License-2.0.txt;md5=8a75796f0ef19c3f601d69857f5a9a5b"
8
9RDEPENDS:${PN} += " \
10 python3-compile \
11 python3-sphinx \
12"
13
14PYPI_PACKAGE = "sphinx_rtd_theme"
15
16SRC_URI[sha256sum] = "cf9a7dc0352cf179c538891cb28d6fad6391117d4e21c891776ab41dd6c8ff70"
17UPSTREAM_CHECK_REGEX ?= "/sphinx-rtd-theme/(?P<pver>(\d+[\.\-_]*)+)/"
18
19inherit setuptools3 pypi
20
21#Fake out the setup scipt
22export CI = "True"
23export TOX_ENV_NAME = "True"
24
25BBCLASSEXTEND = "native nativesdk"