diff options
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_69.2.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-setuptools_69.2.0.bb | 55 |
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_69.2.0.bb b/meta/recipes-devtools/python/python3-setuptools_69.2.0.bb new file mode 100644 index 0000000000..897398afc5 --- /dev/null +++ b/meta/recipes-devtools/python/python3-setuptools_69.2.0.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" | ||
2 | HOMEPAGE = "https://pypi.org/project/setuptools" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=141643e11c48898150daa83802dbc65f" | ||
6 | |||
7 | inherit pypi python_setuptools_build_meta | ||
8 | |||
9 | SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch" | ||
10 | |||
11 | SRC_URI += " \ | ||
12 | file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch" | ||
13 | |||
14 | SRC_URI[sha256sum] = "0ff4183f8f42cd8fa3acea16c45205521a4ef28f73c6391d8a25e92893134f2e" | ||
15 | |||
16 | DEPENDS += "python3" | ||
17 | |||
18 | RDEPENDS:${PN} = "\ | ||
19 | python3-2to3 \ | ||
20 | python3-compile \ | ||
21 | python3-compression \ | ||
22 | python3-ctypes \ | ||
23 | python3-email \ | ||
24 | python3-html \ | ||
25 | python3-json \ | ||
26 | python3-netserver \ | ||
27 | python3-numbers \ | ||
28 | python3-pickle \ | ||
29 | python3-pkg-resources \ | ||
30 | python3-pkgutil \ | ||
31 | python3-plistlib \ | ||
32 | python3-shell \ | ||
33 | python3-stringold \ | ||
34 | python3-threading \ | ||
35 | python3-unittest \ | ||
36 | python3-xml \ | ||
37 | " | ||
38 | |||
39 | BBCLASSEXTEND = "native nativesdk" | ||
40 | |||
41 | # The pkg-resources module can be used by itself, without the package downloader | ||
42 | # and easy_install. Ship it in a separate package so that it can be used by | ||
43 | # minimal distributions. | ||
44 | PACKAGES =+ "python3-pkg-resources " | ||
45 | FILES:python3-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*" | ||
46 | RDEPENDS:python3-pkg-resources = "\ | ||
47 | python3-compression \ | ||
48 | python3-email \ | ||
49 | python3-plistlib \ | ||
50 | python3-pprint \ | ||
51 | " | ||
52 | |||
53 | # This used to use the bootstrap install which didn't compile. Until we bump the | ||
54 | # tmpdir version we can't compile the native otherwise the sysroot unpack fails | ||
55 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" | ||