diff options
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_56.2.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-setuptools_56.2.0.bb | 55 |
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_56.2.0.bb b/meta/recipes-devtools/python/python3-setuptools_56.2.0.bb new file mode 100644 index 0000000000..bb852d0652 --- /dev/null +++ b/meta/recipes-devtools/python/python3-setuptools_56.2.0.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" | ||
2 | HOMEPAGE = "https://pypi.org/project/setuptools" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6" | ||
6 | |||
7 | inherit pypi setuptools3 | ||
8 | |||
9 | SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch" | ||
10 | |||
11 | SRC_URI += "file://0001-change-shebang-to-python3.patch" | ||
12 | |||
13 | SRC_URI[sha256sum] = "7bb5652625e94e73b9358b7ed8c6431b732e80cf31f4e0972294c64f0e5b849e" | ||
14 | |||
15 | DEPENDS += "${PYTHON_PN}" | ||
16 | |||
17 | RDEPENDS_${PN} = "\ | ||
18 | ${PYTHON_PN}-2to3 \ | ||
19 | ${PYTHON_PN}-compile \ | ||
20 | ${PYTHON_PN}-compression \ | ||
21 | ${PYTHON_PN}-ctypes \ | ||
22 | ${PYTHON_PN}-distutils \ | ||
23 | ${PYTHON_PN}-email \ | ||
24 | ${PYTHON_PN}-html \ | ||
25 | ${PYTHON_PN}-json \ | ||
26 | ${PYTHON_PN}-netserver \ | ||
27 | ${PYTHON_PN}-numbers \ | ||
28 | ${PYTHON_PN}-pickle \ | ||
29 | ${PYTHON_PN}-pkg-resources \ | ||
30 | ${PYTHON_PN}-pkgutil \ | ||
31 | ${PYTHON_PN}-plistlib \ | ||
32 | ${PYTHON_PN}-shell \ | ||
33 | ${PYTHON_PN}-stringold \ | ||
34 | ${PYTHON_PN}-threading \ | ||
35 | ${PYTHON_PN}-unittest \ | ||
36 | ${PYTHON_PN}-xml \ | ||
37 | " | ||
38 | |||
39 | do_install_prepend() { | ||
40 | install -d ${D}${PYTHON_SITEPACKAGES_DIR} | ||
41 | } | ||
42 | |||
43 | BBCLASSEXTEND = "native nativesdk" | ||
44 | |||
45 | # The pkg-resources module can be used by itself, without the package downloader | ||
46 | # and easy_install. Ship it in a separate package so that it can be used by | ||
47 | # minimal distributions. | ||
48 | PACKAGES =+ "${PYTHON_PN}-pkg-resources " | ||
49 | FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*" | ||
50 | RDEPENDS_${PYTHON_PN}-pkg-resources = "\ | ||
51 | ${PYTHON_PN}-compression \ | ||
52 | ${PYTHON_PN}-email \ | ||
53 | ${PYTHON_PN}-plistlib \ | ||
54 | ${PYTHON_PN}-pprint \ | ||
55 | " | ||