summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_36.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.5.0.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
deleted file mode 100644
index 63f241809e..0000000000
--- a/meta/recipes-devtools/python/python3-setuptools_36.5.0.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1require python-setuptools.inc
2
3DEPENDS += "python3"
4DEPENDS_class-native += "python3-native"
5DEPENDS_class-nativesdk += "nativesdk-python3"
6
7inherit distutils3
8
9DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
10
11# The installer puts the wrong path in the setuptools.pth file. Correct it.
12do_install_append() {
13 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
14 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
15 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
16}
17
18RDEPENDS_${PN}_class-native = "\
19 python3-distutils \
20 python3-compression \
21"
22RDEPENDS_${PN} = "\
23 python3-ctypes \
24 python3-distutils \
25 python3-email \
26 python3-importlib \
27 python3-numbers \
28 python3-compression \
29 python3-shell \
30 python3-subprocess \
31 python3-textutils \
32 python3-pkgutil \
33 python3-threading \
34 python3-misc \
35 python3-unittest \
36 python3-xml \
37"
38BBCLASSEXTEND = "native nativesdk"