summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_19.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_19.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_19.2.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_19.2.bb b/meta/recipes-devtools/python/python3-setuptools_19.2.bb
new file mode 100644
index 0000000000..bb5798229f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_19.2.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://packages.python.org/setuptools"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8DEPENDS += "python3"
9DEPENDS_class-native += "python3-native"
10
11SRC_URI = " \
12 http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
13"
14SRC_URI[md5sum] = "78353b1f80375ca5e088f4b4627ffe03"
15SRC_URI[sha256sum] = "f90ed8eb70b14b0594ba74e9de4ffca040c0ec8ee505cbf3570499467859f71a"
16UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/setuptools"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit distutils3
21
22DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
23
24do_install_prepend() {
25 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
26}
27#
28# The installer puts the wrong path in the setuptools.pth file. Correct it.
29#
30do_install_append() {
31 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
32 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
33 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
34}
35
36RDEPENDS_${PN} = "\
37 python3-distutils \
38 python3-compression \
39"
40RDEPENDS_${PN}_class-target = "\
41 python3-ctypes \
42 python3-distutils \
43 python3-email \
44 python3-importlib \
45 python3-numbers \
46 python3-compression \
47 python3-shell \
48 python3-subprocess \
49 python3-textutils \
50 python3-pkgutil \
51 python3-threading \
52 python3-misc \
53 python3-unittest \
54 python3-xml \
55"
56BBCLASSEXTEND = "native"