summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-scons_3.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-scons_3.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-scons_3.1.2.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta/recipes-devtools/python/python3-scons_3.1.2.bb b/meta/recipes-devtools/python/python3-scons_3.1.2.bb
deleted file mode 100644
index ce117a92d4..0000000000
--- a/meta/recipes-devtools/python/python3-scons_3.1.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE-python3-scons-${PV};md5=e14e1b33428df24a40a782ae142785d0"
5
6# pypi package does not have a valid license file
7SRC_URI += "https://raw.githubusercontent.com/SCons/scons/${PV}/LICENSE;downloadfilename=LICENSE-python3-scons-${PV};name=license"
8
9SRC_URI[md5sum] = "f9c4ad06dcf1427be95472eaf380c81a"
10SRC_URI[sha256sum] = "8aaa483c303efeb678e6f7c776c8444a482f8ddc3ad891f8b6cdd35264da9a1f"
11SRC_URI[license.md5sum] = "e14e1b33428df24a40a782ae142785d0"
12SRC_URI[license.sha256sum] = "72ed889165fb28378cadac14552be4a959f1ebab6b148abb5dd2b49712c3c6f6"
13
14S = "${WORKDIR}/scons-${PV}"
15
16UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
17UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
18
19inherit pypi setuptools3
20
21do_install_prepend() {
22 sed -i -e "1s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/script/*
23}
24
25RDEPENDS_${PN}_class-target = "\
26 python3-core \
27 python3-fcntl \
28 python3-io \
29 python3-json \
30 python3-shell \
31 python3-pickle \
32 python3-pprint \
33 "